Problem Exporting Game As Runtime

Ok so after much slaving and hair-pulling-out I’ve finally got a small game I’d like to call finished. To completely finish it though I’d like to export it as a runtime.

This is where my problem comes in. I’m using Win XP SP3, 8500GT video card. When I export as runtime using File > Export, everything seems to go fine, until I run the game. It comes up with the window for the game, but appears black. After a few seconds, it crashes.

So for the last couple of hours I’ve been doing as much searching as I can on the forum and found a few people with the same problem but couldn’t find a solution. I’ve narrowed it down to my textures. If I unpack the textures from my .blend, the runtime will work fine, albeit very bland. As soon as I pack the textures back in, crash. I’ve tried every way I know possible of packing the textures, watched a few Youtube videos of how people do it, nothing seems to work.

I also tried copying the .dll files from the Blender folder in Program Files and the Python folder too, no change.

Would anybody be able to help me? I’m thinking it could even be just my computer so I’ve saved a run-time into a .rar file with textures (the one that crashes on my comp), its 16mb so too big to upload if somebody would be kind enough to pm me their email address and I’ll send it to them and you can give it a try and let me know if it works?

Also I’d prefer not post the .blend just yet. Once I get this working I’ll put the runtime in the finished games section and I’ll probably throw in the finished .blend there :slight_smile:

Thanks in advance for any help!

That’s odd. I just tried it with my game, and both packed and unpacked textures worked fine. Game plays fine, no crashes. What version of Blender are you using? I was using 2.64.1.

EDIT: And you could upload it elsewhere, like or MediaFire.

Using Blender 2.64.0. Would that make a difference? Unfotunately the .blend files are on my work computer so I won’t have a chance try with 2.64.1 until tomorrow morning :stuck_out_tongue:

Ok so just downloaded the latest version from and its still 2.64.0. Below is the link to the test one (textures packed, crashes on my comp):

Didn’t work with mine either. Also didn’t work when I tried to stick the DLLs and 2.64 folder from a runtime that I made that worked into your game (because you probably aren’t using 2.64.1. Try either 2.64a from if you haven’t downloaded that one, or a BuildBot / Graphicall build).

I would recommend trying to distill your blend file down to the texture / resource that’s causing the problem (i.e. make the simplest blend file that exhibits the problem), post the blend file that’s the problem if it’s simple and you don’t mind, or just keep the textures unpacked until the problem’s figured out.

I have to say that im getting crash’s aswell and i can’t seem to isolate it, i’m absolutely positive its not the textures. After further testing ive come to the conclusion this is a serious issue and definately needs to be addressed next release.

The moment i apply any object with any texture in GLSL, i get a crash. i cant even debug it.

Windows 7

Blender 64 2.64a off official website.

ok located the problem, my fault, i kinda feel like a tool. Its something to do with missing files from the blender folder, i just ended up copying the entire blender 2.6.4 folder as a test to see if it would work and it did.

Hope this helps

I fixed mine. I found another computer with GLSL capabilities and for some reason on that computer, one of the spec maps was some random texture that I hadn’t even created. So just replaced that texture with the proper one, packed everything in again and all worked fine :slight_smile: