Problem getting armature animated in game mode

Hi all,

First, here is a link to my file: test.blend. I am trying to follow the Game Engine tutorial on BlenderCookie but now I am getting stuck. I created a small character with an armature, created a small walk animation and try to create the <sensor,controller,action> system (with up and down arrow) to make it walk while playing the game.

My character seems correctly rigged, with the armature as a parent of the character (not as an Object) but still that little guy is static when the game is running… :confused:

Would anybody have have an idea? :slight_smile:
Thanks a lot for your help.


test.blend (745 KB)

I could not download your blend (always have problems with mediafire) try to upload your blend here
I would like to see it


hey i could download it but it just crashes my blender program.

go to edit post -> go advanced -> upload file

Thanks a lot for your help! I just attached the file.
I also forgot to say that I use Blender version 2.54 Beta (r32511). It shouldn’t change anything but I use the linux 64bits version.

Ah sorry that might be the reason I can’t open the file.
first, I have 49b and second, i dont think I can open linux

Well Linux and Windows files should be compatible anyway.
But with 2.49 that may cause some problem yeah :yes:

Yeah, i am using 2.49a right now. If you can make a 2.49 version and upload


Hi. I don’t know why, but you have to add an Armature modifier.



test.blend (693 KB)

Well when you add the armature modifier, the mesh is “bended” in the game but it doesn’t get animated.
But I made a test with blender 2.53 alpha instead and it worked! So it looks like there is either a bug or a modification in version 2.54 which makes armatures acting differently in the Game engine.

Anybody has an idea before I post an issue on Blender Bugtracker?

Did you tried my edit blend file? The animation is working with the armature modifier in the game engine in Blender 2.54.


Well the first time I answered, your file was not working neither. But as I was confused by your second post, I tried again.
And it looks like the blender 2.54 from the Blender site is working with your file (build time: 11-Sep-2010 23:20). But the one I use (which is a kind of nightly build for Ubuntu “”, build time: a few days ago) does not.

So it looks like this problem started in version 2.54 at some points during the last month :).
However it looks a bit unnatural to “apply” the armature a second time through a constraint.

Bug has been posted:

A workaround is to apply the armature modifier first before any other (especially subdivide).

i recently followed that tutorial also, i found setting the parent manually in object tab did not work, but selecting mesh and press ‘alt+p’ to clear parent, then shift select armature and ‘ctrl+p’ to set parent ‘Armature Deform’ made it work in BGE.