Problem: Hair keeps jiggling (Not using hair dynamics)

In my scene I have a boy with short hair. This hair has no hair dynamics enabled, and should remain static. The problem I am having is that when I render my animations out, the characters hair seems to jitter or ‘dance’ around at random.

A video example can be viewed here (H.264 Quicktime) http://www.cinepanache.com/files/HairProblem.mov
As you can see, this problem is easily viewable in the characters bangs in this particular shot. However, the problem occurs all over the head when viewed from different angles.

Things I have tried: Double and Triple checked that no odd weight paint problems were present. Rendered with both “b-spline” enabled and disabled.

Attached are my current partical settings.



Here is pt2


And these are some of my current material settings.

Any suggestions would be greatly appreciated as this is a problem I have been wrestling with for awhile now.

I think the hair is flickering more than moving around. The Sintel team ran into this and didn’t have a good solution, other than trying different settings as you have.

http://wiki.blender.org/index.php/Org:Institute/Open_projects/Durian/HairNotes

Sometimes it can help to render hair out to an image sequence (.png) rather than straight to a movie format, then assemble in the VSE, but no guarantees.

I’ll give those notes a look. This video I have posted was originally a PNG image sequence which I compiled into a video afterwards. So unfortunately in this case, the problem remains.

Hmm… I read through the notes, but can’t seem to find the solution anywhere. It seems the Sintel team’s problems were arriving from the use of hair dynamics where my character does not use that.

So after banging my head for weeks now, I finally have a solution that seems to work consistently across all scenes in my movie, and with all characters. The trick is to adjust the virtual parents slider in the “children” tab of the particles panel. In my case, I have adjusted it to the mid point (0.5000) When I do this, the hair is visually the same, but the jiggling or flicker ceases to exist. Also, since this is a children variable, it can be applied after having combed the hairs.

This appears to be the solution I’ve been hunting for, and I hope it helps others. Perhaps someone too can offer an explanation as to what exactly “virtual parents” is doing and why it seems to solve this really annoying problem.

Thanks for sharing your solution, even if we don’t understand why it works :slight_smile:

It wouldn’t shed light on “why” it works, but it might be helpful to do some testing on various hair configurations to see how that setting affects the results, such as with strand-rendered hair vs. raytraced, etc., and at various “virtual parent” settings. That’d at least provide a set of empirical observations that might make choosing effective values easier.

And again, thanks for posting your solution!

Well in my case I have strand-rendered hair activated, as well as B-Spline with the default 3 segments. One thing to note which may help is that I had this problem when using blender 2.56, but when I activated B-Spline, the problem went away. However, in 2.57b, this problem came back despite keeping the same settings. Now the big difference between those two versions is that 2.57b has “Parting Controls” in the children tab, where as 2.56 had that space reserved for these controls, but they did not exist yet.
When this “virtual parents” setting is changed from 0, this parting controls section is disabled automatically and is no longer available as long as you are using virtual parents.

I personally don’t have time to run tests on this with different settings as I must dedicate my computer time to rendering for my project at the moment as I am in a bit of a crunch time with all of this. However, if anyone wants a blend file of this, I’d be happy to provide a stripped down version of this shot.

I would log this as a bug, so hopefully the particle devs will fix this behavior.