Problem: Knife Tool Strange behavior

Hi there folks!

I’m experiencing a strange behavior with the Knife Tool. As you can see in this GIF it works like if it were mirrored across the first cut point.

I’m using Blender 2.69 and I have this problem in all the objects in the scene but don’t in other ones.

I want to report it as a bug but I want to be sure that it is.

Thanks in advance!

Not enough info. What modifiers do you have on that object? Are there any unapplied scalings or rotations? Best to post a .blend file that demonstrates the problem so other people can test and confirm before you report a possible bug, and even if you do report a bug this description is insufficient to get it addressed properly.

it may be that you are in perspective view.

paolo

Thanks for your response.

K Horseman: I only have an Edge Split modifier and the scale is 1. I couldn’t post the Blend File cause is a commercial project with paid models inside. Even so, I planned to post a simplified .blend when reporting as a bug. I’ve just figuring out if I was missing a simple topic.

souvirnos: I thought that you were insane but… it works!!! If I work on an ortho view the Knife works just fine. But if I work in perspective view on a long distance from the model it works too. It’s crazy! It never worked like this before. Is this a known bug?

I’ve checked if the view’s clipping options may cause this, but it doesn’t.

Thanks again for your interest guys :wink:

Rather than a bug, I would say a sort of limitation.
Perspective view is not the best for projecting rays, so if the angle of view is too large it can fail.

paolo

In my case I experience that issue when I’m close to the object and works fine if I’m far. And it’s the first time that I’m having this problem.

If you’re telling me that it’s not a bug I’m fine. You give me the solution anyway :slight_smile:

I’m prone to think it is a known issue, which maybe will be corrected in the future, what you have experienced has a sense to me.

Perhaps somebody else can cast some light on the matter, and suggest if it would be the case to submit a bug report or not.

paolo

There have been several bug fixed with the knife after the 2.69 release, so maybe that perspective knife problem is now fixed, give a try to a more recent version of Blender on the buildbot (as it contains the fixes for the knife that the 2.69 release does not have) to see if it works better for you :
http://builder.blender.org/download/

Hi, I am struggling a bit with knife tool also, sometimes it creates double vertexes on edges while cutting, around 2 of 10 cut points are broken. It seems that this is happening with large objects for example 100x100x100m. Is there a way to fix this issue instead of modeling object smaller and after it is finished - scale it to proper size?

Thanks Sanctuary! I’ve checked the file with the last build and it’s totally fixed :slight_smile:

We are using blender 2.7 series in the studio and still the problem persists . the problem is also there in the orthographic view and looks kinda random :frowning: . why is such an important tool so badly maintained?!

You’re being too hard on yourself, and on your supervisor!

Anyway back to the Knife, which one of the many problems described in this thread are you having? Could you provide a screenshot, a verbal description, a blend file etc. so we can see if the problem is reproducible.

:eek::confused: . thats my work and i have to ans questions by artists for problems that are supposed to be solved around 10+ years ago … cant help it … hehe and knife tool is the most abused in modeling .

anyways… here is the detailed description of the problem …

BLENDER - v2.71


  • this is where he cuts using the knife tool in orthographic view


  • this where it screws up by adding double vertex at the cut points :frowning:

i have the same problem with other artists here but with perspective view for which the solution is to change to orthographic and continue the work . for some its the opposite . :frowning: . but for some this problem never exists . :rolleyes:

I may not be able to send the model since its still a WIP and an IP . let me know if this was helpful .

No need of the whole model you’re working on, you should just delete all that is not needed to reproduce the problem.
This way it can be reported and hopefully fixed, because i tried to reproduce your case in 2.71 , even adding a subsurf too as i remember in the past there were some problem with knife and subsurf that were supposed to be solved :

In ortho mode :
http://i.imgur.com/qW0xXqy.jpg

And it seems to cut correctly
http://i.imgur.com/iC66xxr.jpg

Then i did an undo and tried the same in perspective mode :
http://i.imgur.com/dFheruB.jpg

Still cutting correctly :
http://i.imgur.com/0aKjbcN.jpg

So there must be something related to the topology of that specific model, some edge angle or something else i just can’t reproduce on my own by eyeballing, what is needed is that part of your model (again, no need of the complete model, just the part in screenshot to reproduce your case) to get this fixed.

Because i agree, the knife is a very important tool, after 2 years of the bmesh new knife having been introduced, we should expect it to cut correctly when we use it, especially on very simple user case like that.

Hi @Sanctuary . this is the file … it works in perspective mode … but not in orthographic . let me know if you have the same problem with this file .
https://drive.google.com/file/d/0B0OIzvVacMnqUWh0OXVzVEFWNVU/edit?usp=sharing

Thanks, i gave a try to it in ortho mode and it seems to work for me.

http://i.imgur.com/s8ymQGM.jpg

http://i.imgur.com/ujmklX1.jpg

Now i noticed your view clip settings :
http://i.imgur.com/hiakanv.jpg

I remember reading about people having trouble with selecting correct vertices/edges in Blender and there seemed to be a link with how their view clip was set at the “Start” value.

So give a try to this : put your mouse cursor there :
http://i.imgur.com/JcpmcAq.jpg
Right click and select “Reset to Default Value” to reset the Start view clip to its default.
Then try again to cut to see if it will work (i didn’t need to do that to make it work though)

And in the case you have some level of multisample in file -> user preferences -> system, try to disable multisample entirely, i remember many people posting about blender not selecting correct vertices/edges with it enabled

additionally, you have unapplied transformations in Object Mode, maybe it’s intended, but if it’s not, select the object (in object mode) and press CTRL+A -> Rotation&Scale to apply them

thanks . i tried all the methods u have mentioned … but nothing seems to work… btw … did u try to select a vertex and check if its really a single vertex? . after using the knife tool in ortho ,try to select a vertex from the cut point and check if it has double vertex .
here is my preference system screenshot


You don’t cut with Subsurf modifier and “Apply modifier to editing cage during Edit mode” enabled, do you? That’s the only way I can trigger the behaviour you describe - at least on my machine.


With that disabled the Knife too works fine here, both in ortho and perspective views.

On the bug tracker i have found (their search engine is really bad) this entry that looks very similar to the bug shrinidhi666 is facing :
https://developer.blender.org/T39387

The only dev that is working on the knife replied a few months ago :

Thanks for the bug report. Knife isn’t well tested with subdivision and I guess I’m not too surprised it is broken. Will dive into this to debug.

So he’s aware of the problem, now hoping he’ll find some time one day to fix it (note that he’s not one of the paid dev and so only works on Blender when he can on his spare time).

So there may or may not be a problem with the knife although I had no problem cutting your model with it.

But there definitely is a huge problem with the normals on your model.

http://imgh.us/capture2_81.png