problem making an exe file


(godofredoiii) #1

I’m trying to make an exe file from an animation I’ve made using the 2.37a version. The animation is based in a .vrml file. It has textures and I’ve used an armature for the movements. I’ve added some commands like pressing some keys in order to make the moves. Two questions:

1- I’ve read in another post that “saving runtime” packed all things in the exe file, but when I try to open it, it asks for “python23.dll” and “SDL.dll”. As they sady in that post, only when saving as “dynamic”, it asks you for those files.

2- When I add those files to the directory, it opens it correctly but a grey screen is displayed. I’ve alredy made an avi file and all was correct. What I’m doing wrong?

Many thanks to all.


(digital_me) #2

The make runtime command is if you have a game that you want to redistribute without requiring blender. You can’t make an exe of an animation.


(godofredoiii) #3

So I can’t make a stand alone program with my animation? Well that’s too bad because I’m making my final degree project and one of the reasons of choosing blender was the posibility of making an interactive program easily. So what about the games I’ve seen made with Blender? How are they made?
If they do’nt use animations, how they make the movements and interactions? Please I need an answer because I’ve worked hard learning to use blender and I wouldn’t like all that work for nothing.
Many thanks.


(Duoas) #4

Relax, all is not lost.

The game engine works by using ‘armatured’ meshes (which have been properly UV-mapped) in blender. The armatures contain attached actions which basically each define a specific animation sequence, such as running, jumping, etc.

The game engine couples this with code that reads what the user does on the keyboard or with his mouse or joystick and responds appropriately.

So you can do what you want to do, but you’ll have to learn Python and how to use the game engine to program it to make your character interactive.

Once it works, you can compile it into a stand-alone exe file that you can distribute.

Good luck.


(OTO) #5

Hello

don’t break your computer…yet
You can use your animations in the game engine, make an EXE, show it to the world became rich anf famous… :slight_smile:

But, you’re a bit confused
Anyway here’s one way of getting your .EXE:

Select one animated object
Go to the Logic window -F4 key
Add a let’s say Keyboard Sensor ( Space key)->AND->IPO Actuator
Set the IPO to the lenght of your animation
Now start the game engine and press the Space key…your object should move?!
That’s the way you get animations in the game engine ( Action Actuator for Armatures)
Now you can save a runtime
You’l obtain an EXE in the Blender directory with the same file name
I’m not a windows user, probably you nedd to add the python and sdl DLL to
the EXE folder and redistribute
Is this clear?
You should read some docs
Bye


(godofredoiii) #6

Hi everyone and thanks for answering.

First, OTO I’ve already done what you said, I have my character (which is a human 3d scanned face) and I’ve made some animation with an armature. I’ve assigned some keyboard keys to certain parts of the action strip to make it smile, move the mouth, etc. When I play the animation in Blender it works correctly and interacts with the keyboard pressing. All perfect. Is when I save the runtime that I get the problem as the executable file displays only a grey screen. I’ve already done a .avi file (with no key pressing, of course) and it works perfectly. So that’s why I’m a little upset.

On the other hand,the idea of learning phyton suits me if its the only way of making it. But I wouldn’t like my project to last forever. Also, as the goal is to make a human model as easy and realistic as possible, and if the only way of making this is in terms of programming, I don’t know if blender is the rigth solution at all. So I’m just a little more upset.

Thanks a lot


(OTO) #7

Ah, sorry, I was wrong.
You know how to do it. Ok.
Save runtimes work perfectly for me ( and many others)
You’re doing a wrong step somewhere
What version of Blender do you have?


(godofredoiii) #8

Hi again OTO.

I’m working with 2.37a.

I’ve tried my animation with 2.40 aplha but it doesn’t move when I try to play it. Maybe a bug when opening files from earlier versions? Don’t know. Also Blender publisher breaks when I try to rotate an specific bone. It’s quite nice.

Any more ideas will be greatfully wellcomed.

Thanks a lot for your help.


(piterx) #9

well,maybe it is best for you to try to save runtime on a different computer. :-?