Problem mapping texture to sphere

Dear Blenderers,

for a scientific project I textured a plane and then wrapped it to a sphere with Blender 2.56. In Blenders camera perspective it looks fine (seamless), but when rendering the texture has a seam (please compare middle part of attached picture; the white blobs should all have about the same size). The texture and the camera are inside the sphere!

I am completely not in the field of computer graphics and wouldn’t know what else information is needed to tackle this problem. Please let me know what other information I need to provide.

Thanks in advance,

Please let me know what other information I need to provide.
Your blend file including all associated textures

Here is the file:
-> texture_fisheye

Sorry forgot the texture file. Here it is:

So, I continued trying to map this and other pictures as texture without success. I followed the instructions on this site:
to wrap the picture. Then I flipped the normals of the sphere to see the texture from the inside.

Now, what I noticed is that if I look in the preview area of the texture tab I see the same seam as in a rendered picture:

But then, if I switch the preview to ‘Large sphere with sky’ it looks correct as in the ‘UV/Image editor’. So I was wondering if I am just missing the right option here to make the rendered output look like in the ‘UV/Image editor’??

Any idea? Somebody?


It depends what you want as a final result. If it’s just the render from your camera you can set the Mapping to Generated and the Projection to Sphere. Because of the orientation this gives to the image mapped to your sphere you’ll need to swap the X and Z options.
You can make stars smaller by increasing the Size value


Juhu, that’s it :slight_smile: . Thank you very much; made my day!

It is usually a problem when noobs use pro tools with so many options.