Problem: Material look with black things when I copy into another .blend (v. 2.83)

I have 2 .blends. In first one I have a full model with all the texture in correct value. Normally i use this model in order to copy and paste the material from eyes, skin, eyebrows, and not need to put manually everytime. In the second blend i have an .obj imported with no textures (separated in meshes) and i select every mesh, and I add the material.

My problem here comes with eyebrows. In original blend looks nice:

r/blender - Problem: Mesh look with black things when i copy into another .blend

But in the new blend eyebrows looks with black things:

r/blender - Problem: Mesh look with black things when i copy into another .blend

The most strange is when I copy the model from second blend (the one with black staff) into the first blend, looks nice:

r/blender - Problem: Mesh look with black things when i copy into another .blend

So it seem is a problem of the second blend, but if I load this again in a new blend, it happens again. I dont understand what could be the mistake. I already checked object data properties, objetct and material properties

I never had this error before, so is not because my way of adding material since i do that a lot with many models. Is the first time I see this.

My blender version is 2.83

Your environment map is different.

Is not because that, I tried different environments, and without environments still looks bad in one render, and good in other…

Then your render settings different. Or any related textures or materials or nodes can not found in the second. Share your settings and we can say anything about that.

1 Like

Im sorry, how can I share my settings? In which place I can find? In preferences? Or do you mean in the panel of objects, data, geometry…?

You can take screenshots or share blend files.

Sure! This is the blend in where the error appears (textures are packed inside .blend)

thank you

Your “Shader Editor > World > Background > Strength” value is low. I set to “1.0”. And your skin shader too confused and I think, it is not right.

And don’t forget: Normal textures must “Non-Linear”, not “sRGB”.

This is your Skin shader:

This is VSHADE’s Skin shader:

Wow, these skin is flawless! sadly i dont have VSHADER hehe.
Anyway, I tried your advice and increment the strengh and still having this in the eyebrows (I tried with many values, 1.0, 5.0, 10., 16.0…) . I think is the eyebrows texture/material, since i hide the rest and I can still seeing weird black things in the texture…

Problem is your shader setup. I check, but too confused. Fix your shader setup and everything will fix.

For Eyebrows, increase Render > Light Paths > Transparency value.

1 Like

Thank you, that was the problem i set transparency value in 20 and now eyebrow looks without the black thing.

Thanks again!

1 Like