Problem modeling a pipe (following Tutorial)

Hi guys. I am very new to blender and the whole 3d modeling scene. What I am trying to do is to model a pipe. I am following this tutorial:

I can follow up until the point where the Subdivision Surface modifier is getting applied. I can apply it, but the result is looking very weird and not like a pipe. Only three of the four sides are getting “rounded”, the bottom side stays flat. I think I am doing exactly what the guy in the video did - why is my pipe so messed up? (Yes, the whole object was selected before I applied the modifier).

Here are screenshots to show what I mean:



Maybe someone here can explain what I am doing wrong?

Remove any duplicate vertices, select all vertices (A) and W / remove doubles)

Hi Dantel,
pipemodeling is much much faster using splines. Add a bezier circle and after adding change the points to free and choose toogle cyclic.
Now you have your base. Delete the two splinepoints at both ends. Enable Bevel and the Fill to full. In or decrease the resolution.
Resolution under Bevel gives you higher profile resolution and under the general resolution of the curve it becomes more smooth in curves.
Just extrude the endings of your curve to get straight pipes and duplicate and or modify your base curved pipe to make it.
Much more control when modeling pipes and 10 times faster :slight_smile:

edit… if you want to have less subd on straight pipes change the handles directing to the straight pipes to vector. If you need some thickness add a solidify modifier.

Making the pipe run out of curve is good. Also Blender has Pipe Joint Add-ons that can create standard pipe joint object. Well, if you have Blender version 2.74 Pipe Joint is in the menu now. You can find it under Add > Mesh > Pipe Joint. If you don’t have 2.74 you need to activate in Preference > Add-ons > Mesh > Pipe Joint.