Problem- objects won't "Set Smooth"

Alright, so attached is an example picture of my problem, but what is happening is that I have a mesh that I have set entirely to “Set Smooth”

After editing for awhile, I rendered and found out that for some reason there are areas in the mesh where it is not smoothing out, but remaining solid. This is seen on the eyebrows and fingertips of the picture (no worries, this is the most intense scene in the animation)

Later on I made another object; the shell of the bullet that kicks out when the gun fired. It too for some reason will not set smooth when I have set it to “Set Smooth.”

This problem only occurs when I render, it shows a smooth surface when I edit it. So I’m guessing there is some setting that might result in making a mesh solid in certain areas. I am using Blender 2.49b, although the problem started at previous versions.

Thank you!


Most common solutions:
Remove any double vertices (select all vertices then Ctrl+N).
Check for any internal faces inside your mesh
Check you haven’t got an Edge-Split modifier
Reset your scale and rotation Ctrl+A / 1



Also check you’ve not enabled autosmooth.

thanks rawpigeon, that was the problem! There’s some sort of glitch, because the 2 objects are autosmoothing despite the fact that the button is set on or off. I didn’t figure it out because it doesn’t apply the change of degrees of the auto smooth until I change the angle of the view. So by setting it to 80 degrees, it removes almost all of the blockiness, which is ok for what I’m doing.

If anybody knows how to turn off autosmooth another way (besides clicking it in the mesh panel) I could try that.

I installed the latest blender on another computer and the problem was still there so it’s something wrong with the file, creating this weird glitch I guess…