Problem parenting a cloth simulation

I’ve been scrounging the internet for some tutorials about pairing up a cloth simulation with a moving character.

This is the only one that I have found yet…

The part I’m stuck at is at 1:18 in the video link above…

Instead of adding an Armature Modifier on both the shirt and the shorts, I simply parented both cloth object to the character root bone.

So, circled in red at the right side. I have the “Cloth Robe” which is also selected in the Viewport, parented to the Armature which is the Human Male Model in the Viewport. Below it, I have the option set to “Bone”. (If I set it to Armature or Object, the Cloth Robe will not follow the movement of my Character)

Now if you look back into the Viewport, you can see that the Cloth Robe is not where it’s suppose to be. (It is ahead of the Person. I’m also some frames into the animation, but atleast it follows the character, sorta. Also the physics is screwed up, it’s acting like gravity is aiming towards the person)

Note: If I was to remove any Parenting, the Cloth Robe will be correctly positioned on the character and it would be at his waist and everything is fine. Except for the fact that it does not follow the character as he moves.
I have a Vertex Group assigned at the top of the Robe, so the Cloth Simulation doesn’t fall to his ankles.

Note2: When the cloth is parented, the picture what you see above is what I see. The position of the Cloth Robe is messed up.
Also the axises are turned 90 degrees and is positioned differently.

When it’s not parented, the Axises of both the Person and the Cloth face the same directions and the Robe is in the right place where you would expect it to be.

–What I would like to know…
(1) How can I have a Cloth Animation, which is the bottom half of a Robe. Be pinned so they don’t fall down, but at the same time follow the movement of a character and move in real-time as a Cloth Simulation. (Any suggestions to keep the cloth from acting like it’s on steroids? The slightest touch of movement causes all kinds of stretching, jumping, jiggling of the material)

(2) Anyone know any “proper” tutorials for my question? :slight_smile:

Trying something a little different. I got it sorta working, but not what I would expect.

So basically instead of parenting the actual Cloth Model to the Person. I used a Bone Constraint > Child Of instead, attached to the Bone I used for the Cloth Model.

What this does…
(1) The cloth animation moves forward as I have wanted it to. But the way it does it is not what I would expect.

What goes wrong…
(2) Obviously you can see that the Cloth is way ahead of the character. It is suppose to follow the “Hips” bone which right above the selected Bone. (The currently one selected is in Teal)

So the Cloth Bone was following the Hips Bone just perfectly, but I have no idea to why the cloth is going on ahead like this.

The strange thing is that if you look at the screenshot, the way the cloth physics is acting like the Legs are actually inside of it. You may not be able to tell perfectly, but when I look at the posture of the Person, and compare it to the Cloth.
It looks like the Legs are placed inside the Cloth.

Going back a couple of frames, when the Cloth is half in & and half out of the Person. The physics is still acting like it is inside of the legs and not in front of it.

Trying to Pin the Cloth doesn’t help and makes the physics interactions even worse.

Any help here?

Are their any more “active” Blender forums with active posters? I see a lot of threads get views, but it’s like typically 100+ views per view, and sometimes some don’t get any.

I’m kind of use to more active responses (24 hours or less), and I would like that kind of interactivity especially with programs like Blender.

This is a simple setup I came up with, that gives pretty decent cape movement. Have a look at the video to see if it would work for you.
If this movement is what you want, I can post the blend. The steps are pretty simple.

  1. Model the cape. I like to keep these flappy flag-like meshes real low poly. It makes for better
    movement and makes baking 5 seconds. Although I may gone too low poly here, a couple more loops would be better.

  2. Weight paint a vertex group called ‘top of cape’. The edges closest to the shoulder get full
    red, the secondary edges get medium weight, the rest are 0. (see image at bottom)

  3. Parent the cape to the armature, auto weights. In the armature modifier,
    set it to use only the ‘top of the cape’

  4. Add a cloth sim, pin it with ‘top of the cape’ Knock the structural down some, up the bending a little.

  5. Keyframe your rig

  6. Add collision to the character object in physics. Bake the cape for those frames.

The embedded youtube player is giving me buffering issue, here’s the you tube link:

Here’s it is in images, let me know if you want the blend.

Can you please next write your explanation better, clearly and/or with images? I’m still not doing something right.

Responding to your numbers with mine… (Blenderartists is giving me issues with linking images)

(0) Mine is 342 Tris with a Multi-Res modifier. I also have a “Solidify” modifier attached to the Robe.

(1) Did that.

(2) Is this correct?

I first selected the Robe Cloth, then went to the “Object” tab which is that 3D Orange Cube. Went to the “Relations” tab and changed it’s “Parent” to “Armature” which is the bone that the Cloth Robe is attached to.

So what you see in the picture is when I select the Cloth Robe and go to the Modifier tab.

(3) Ok I have the Cloth pinned to the Vertex Group shown in the 2nd picture above.

(4) The Human Rig is already moving (Stays still for the first 30 frames to settle the cloth) and moves 20 frames.

(5) The Human male has collision, but how do I do the baking and what is the benefit/need for it?

What you did is basically what I want, I want my Human model to move around, jump, frontflip, while the cloth animation is simulated. (For this particular animation scene, I don’t want to worry about posing the cloth)

Edit: oh dude, I just looked at your modifiers, the cloth sim needs to come after (below) the armature in the stack.

See those little arrows (by red dot), the armature needs to be at the top. The armature tells the top of the cape where to be, and then the cloth sim figures outs where the rest of it should settle, sway. Here are my modifers, if i were to add a solidifiy it be one above the subsurf.

My feeling is that the multires and the cloth sim may be fighting, especially if the cloth sim is below it in the stack. There’s so many piece involved in this type of sim and so many variables, that I would really need to see the blend. There are also multiple ways to get the effect, mine is just one. If you can post the blend, that would be best.

The issues I see with your steps,
2) When I parented the cape to the character, I selected (right-clicked) the robe, hold shift and select the armature and hit Ctrl-P “automatic weights”. This creates vertex groups for all the bones, and I probably should just parent it a single bone, but since I’m only using the top of the cape it doesn’t matter much.

I guess you are just hitting alt-a in the viewpprt to see the cloth sim. In effect you are baking when you do that, it’s just a bit clunky.
Usually I figure out how many frames my animation is and set that in the cloth cache settings (See image) click ‘bake’ and it does all of the simulation calculations and then you can just watch it in closer to real time (in my file it is so small it is in real time) The bake data is more persistant and faster to do since it’s not trying to update the viewport constantly.

I can probably do more of a step by step thing, but honestly It would better if you posted your blend for other’s to look at. It’s entirely possible there is some other unknown issue that makes all this moot. or dropbox are good/free hosting choices if the blend is too large for BA. I would be happy to look at it. Good luck.

Here is the blend file…

I’ve tried doing what you said, moving the Armature to the top, then the cloth simulation. (Got rid of my Multi-Res & Solidify temporarily to see if it would work, no effect)

My armature is properly attached to the Robe, (If I go in Pose mode, I can rotate the bone and the robe will follow suite)

Here are some of the “unknown issues” with this sim. You really must address each one before you will have success here.

  1. The cape and skirt do not have aplied scale/locations or rotations. Ctrl-A, do them all
  2. The person01 rig has unapplied scale.
  3. You have keyframed the scale of the skirt, delete that in the dopesheet, that will really make for odd behavior. Edit: Just realized you had auto keyframing on, turn that off for fixing things.
  4. You have created a separate one bone armature for the clothes, and parented them to it. They should be parented to the person01 rig. Just delete the armature named ‘Armature’
  5. The faulty armature modifier was still at the bottom of the stack.
  6. You have modeled the clothes to fit in a posed position. They should fit in the REST position.
  7. get rid of the multi-res for now. It’s just a monkey wrench you don’t need.

There are more, smaller issues, but truthfully each and every big issue I mention is enough to make the sim not work (each in a new and wonderful way!). Try working on these one by one, and see if you can make some headway and let us know how it goes.

On a positive note, the walking animation looks very good, and if you keep banging at this, you’ll get it. Good luck!

1 Like