problem regarding alpha channel transparency and shadow

Hello,

Tweaking a few ideas concerning some projects textures, i am running into a problem that i don’t know how to solve.

As the models are a bit complex, i’ll use a much simpler example to explain it.

A plane is above a cube.
http://i.imgur.com/Fp1Kfs.jpg

The plane is using a texture that has alpha channel
http://i.imgur.com/rwC65s.jpg

So you don’t see the plane, only the texture floating above the cube, if i preview it with a simple light, it looks as expected
http://i.imgur.com/JM3M1s.jpg

Now the problem is when i use ambient occlusion, suddenly the plane make a shadow on the cube, that is totally unwanted.
http://i.imgur.com/Y6abms.jpg

The plane has every cast/recieve shadow disabled in the material tab, so i don’t understand why it is making a shadow with ambient occlusion.
Is there a solution to this other than disabling the ambient occlusion ?

I attached the simple .blend from the situation described in this post (texture is packed in it) to see if someone can help find a solution