Problem saving and loading preferences

I’ve installed 2.54 beta on my home and work machines, both using vista 64. I’ve setup custom hotkeys but all I can do is the ctrl+u save as default. Trying to make a preset doesn’t work (I click + then type a name but nothing happens even after pressing enter). Also tried saving a scene then opening it on the other machine and it just gives an error saying it can’t load the file because it isn’t a blender file (despite it being a .blend).

Could this be something to do with python? I’ve only installed blender, really don’t know anything at all about python or how to do things like do builds.

When you hit ctrl-u it saves the defaults that you set automatically in it’s own file, which would be the .blend that you are talking about. I think the name is startup.blend, but it used to go by the name b25. Anyway, you don’t have to save it with a name, and it loads automatically each time you start Blender. Copying this file from it’s directory onto another computer in the identical directory will cause Blender to load it every time it starts.

This should be found in some place like this in Windows 7 c:\users[name]\AppData\Roaming\Blender Foundation\Blender\2.54\config\startup.blend

You might want to get a newer build, there have been fixes and code reorganisation regarding presets.
I create the official beta builds for Windows, perhaps you might want to try last weeks build from my blog (and hosted on, of course :wink: ) while waiting for the next official release. If you follow my blog, you’ll see when I make newer builds available for testing.


Much appreciated guys. I’d tried to copy the startup.blend file across before but couldn’t find it so that helped. Also downloaded the latest build as suggested and that lets me save presets now.

That calls for a \o/



one questions here

has the keymap bugs problems been solved when saving theses preferences or is it still on the list of bugs?

happy 2.5