Problem: Texture Painting with Stencils

Hello everyone,

This is my first post here but from other threads on this forum everyone seems rather nice and eager to help. I hope you can help me with my issue.

Issue:
I followed a tutorial (Create a Rocky Video Game Terrain in Blender) and have been stumped by an issue (rather big one in my opinion) on Day 3 of the tutorial.

When I try to paint a stencil using texture paint like in the Day 3 video tutorial (~16:30 mm:ss) I am not seeing the same view which he is seeing in the 3D view port (See below for images). He sees his textures coming through on the mesh as he paints on his stencil. I only see a black mesh with white being painted over it (as if the stencil is being used as the colour for my mesh). He moves rather quickly through the tutorial in some parts so I am wondering if I am doing something wrong.

Tutorial:
http://img534.imageshack.us/img534/2163/texturepainthelp01.jpg

Mine:
http://img5.imageshack.us/img5/7350/texturepainthelp02.jpg

As you can see in mine, the render comes out fine. The issue is it is very difficult to paint in textured detail if I have to guess where to place it. It would be much easier if I could do it the way he does in the tutorial. I was able to get a texture in the textured view once I UVmapped a texture but I could not get the stencil to work after that.

Any help or insight is very much appreciated as this is really holding me back right now from completing things.

Thanks,
Emp

Edit: Here is another video demonstrating what I want to accomplish (http://www.youtube.com/watch?v=duDVUb5A4-8 albeit a little more complicated than I want to get but the idea is there). What do you have to do (or not do) to see your textures in textured view mode in the 3d view port (as all seem to get are black).

I’ve not watched the video and the images don’t show all the important stuff. One thing to try is turning on GLSL texturing (if your video card supports it) from the Game / Blender GLSL Materials menu at the top of the screen. This may help with the 3d view. Don’t know if it’ll help but worth a try.

Richard

Hi Richard,

Thanks very much! That seemed to do the trick. I knew it must have been a simple option I was missing.

Thanks again,
Emp