Problem using curve modifier

I followed the instructions in a tutorial, and it worked for one air-duct, but not another, even though the two are almost identical in setup. The tube tends to twist along the curve, I don’t know why. In the image below you’ll see a horizontal tube with a rectangular section at one end and a flat elliptical section at the other end. That’s the straight master tube I use for the two cooling air ducts. But although the tube on the left worked out well, the one on the right has ugly deformities.

And if I switch to Edit mode, where the modifier is not enabled, the mesh appears near the straight master tube without following the curve, but still with deformities.

This is what my paths look like:

Though, I just notice, the tube on the left seems to have subdivision, while the one on the right doesn’t… I’m confused…

EDIT: Yeah, never mind the confusion. What happened is that after my left side tube was working well I applied it, then added subdivision, whereas the tube on the right never worked so it is still a curve modifier. But so my question is still why is it not working, and why does the tube seem to twist?

Perhaps curve control points are rotated.

That crossed my mind, but thing is, I would not know how to rotate them, or how to unrotate them for that matter.
But there’s something even weirder… If I move my air duct along X, it flows through the curve, but past the end points of the curve, Blender projects straight lines, right? But moving the duct in X past the ends of the curve, the duct looks straight but twisted. It is as if there was some spurious curve modifier on it giving it twists BEFORE it gets deformed by the desired curve.
The problem is I have no clear picture how this modifier works. I remember I had to do things in two different places to get it to work, following the tutorial, but now I don’t know how to even inspect the setup. I can’t find where I put those video tutorials. Probably in a USB stick…

As @acrivec pointed out vertex is probably rotated (It’s called Tilt in curves for some reason).

When you right click in edit mode you see tilt options and its shortcuts.

tilt

1 Like

Thanks; that sounds promising. For some reason, however, I do not get the context menu when right-clicking my curve. And if I go to the menu Curve, at the bottom, I find no mention of Tilt.
Using rev 2.76 of Blender, though, on Windows XP.
I could try on the other machine here; I have a Windows 7 box on the other desk.

If you’re using right click select, W is the shortcut for context menu. You can also access those tilting options from Control Points tab above:
image