Problem: When Joining Two Objects the Image Appears on Other Object

Hi, I want to join two objects so I can append them as one object but the problem is after I “join” them (CTRL + J Key) the clock face is being merged or shows up on the clock rim.

I tried parenting the tow but I don’t like that option because then when I append the clock to another file only the rim or clock face appends.

How can I group or join the two objects and then name then “clock” so I can append “clock” to a new file and both objects will be imported?

How can I do this so the clock face doesn’t mix with the clock rim?


Select all objects needed for your group, ctrl-G to create group, rename in your operator window or in the outliner. Adding more objects to the group is as simple as selecting them, shift-ctrl-G to add to a group, and a drop down menu appears to choose from of existing groups in your file. When appending, all the objects in the group appear and they don’t share textures/materials unless you do that yourself.

Makes me curious what’s your mesh and how you get this result exactly. When i Ctrl-J join uv textured plane and frame torus i get one object wth two materials and there is no any “bleeding” from plane to what was torus. Due to subsurf plane does have some loops.


Thanks Craig. I tried to group the objects (CTRL + G Key) but it doesn’t do what I want. It doesn’t make both objects into one single object even when appending. Also when appending the texture doesn’t append with the plane. Am I missing something?

Thanks eppo, hi so I dragged the plane up and then rendered it again, you see the texture is mapping to the clock rim. I am using Cycles if it makes any difference. All I did was map a clock face to a plane and then used a curve to create the clock rim, I then converted the curves to geometry using (Option/Alt + C), then CTRL + J to join and this is what I get. :frowning:


In edit mode, select the ring and hit the plus to add a new material slot and hit assign, and then you should be able to have two materials in one object.

Hi, thanks. I didn’t have any material assigned to the clock rim so do you think that is why the clock face was mapping to the clock rim? When I created a material for the rim then the clock face didn’t seem to map to the clock rim. The clock face seems to go wacky when I “join” it to the clock rim still but that must be due to the face I haven’t properly unwrapped the clock face yet.

It is likely due to cycles assuming you are meaning it to share the same material as the clock face - set up a new maerial for the ring and try joining then.

Cycles had never assumed anything for me; they rather refuse to do what i want ;). Like this time too i’m not able to reproduce this texture “projection” effect. With or without material on the rim. Maybe you use UVProject modifier?



Edit: Only difference is that i initially had unwrapped plane to get texture on it.

if you join one ob no mat to another one with mat it will all become same mat
so i think it is the reason why it’s map all over the 2 OB joinned together!

only way is to add mat to each object so that yu get 2 material when joinned!

salutations

Thanks. Yes that worked! :slight_smile: Now I need to unwrap the clock face.

No modifiers were used. I think it’s because you unwrapped the clock face first. I was lazy and didn’t unwrap initially. I think if you tried this without unwrapping the plane, then you would get the same problem. :slight_smile:

That makes sense! Just learned something new about cycles materials. :slight_smile:

Without unwrapping cycles do not show texture at all. So, yes, i start by unwrapping. But you then likely did unwrap ALL joined mesh while you needed to unwrap just L-selected plane part and then Ctrl-I invert selection and assign another material to that…