problem with 3d model, keeps cutting pieces out

I am new to Blender and I have just drawn a 3D model. I have it in the textured viewport, and whenever I orbit around the model pieces get cut out so I can see inside of it. When I orbit to the opposite direction, the other side is solid but the closer side is gone.
If I put it into the shaded, or solid viewport everything is normal, but when I play the game, it goes to the textured viewport. Is there anyway to stop this cross-section type thing happening?

Some of your face normals are pointing in the wrong direction. In edit mode select all vertices (A) and recalculate normals with Ctrl+N

Sounds like camera clipping issues…
Check your camera clipping settings and reduce the near clipping setting (IIRC the default is 0.1… try changing it to 0.01)

thankyou very much guys. The recalculating normals worked like a charm :yes: