Problem With A Blender Model

I’m pretty new at using blender so I have no clue how this happened but any help would be appreciated
So when I open my blender file to edit the model it shows up like this:

(Image on the right is the scaled down version)

That hole in the middle shouldn’t be there, and before anyone says so yes the polygon’s are there. I can scale it down and the problem seems to be fixed but the minute I save and reopen it the model is right back to the way it was (in the first image).
It does the same thing when I export it, right after it scales back to where it was before.

I’m not sure what the problem is but I have to submit this file soon and if it shows up like this I’m worried I’ll fail the assignment.
It worked perfectly fine before, I had an export file that went into substance painter and it worked perfectly, same when I imported it into blender.
Anyone know what the issue is?

Could be a viewport clipping issue. In the “N” menu | View tab - check the start/end points in the clipping section.

1 Like

Changing the clipping worked, start as 3m and end as 5000m
It seems to still disappear when I try to change the view with the mouse instead of by clicking the viewpoints but thats not as big a deal compared to the hole in the model

Thank you for the advice it was a great help

1 Like

Good! Check your scale, too. Sometimes your model may be “huge” in real world scale - and you can get inconsistent viewport results between users viewing it in their systems.
Take a look through the results here and see if anything may help.



As @Daf57 suspects, your issue is likely that you didn’t consider scale and modeled your object either too large or too small. I suspect too large myself.

Or if it is modeled to very specific and accurate scale then adjusting the camera clipping settings is indeed the way to go.


Turns out my model is huge XD
Scaling it down a ton did wonders, it no longer disappears so its a huge relief
Thank you~