Problem with alpha channel viewport rendering

I’m having this issue in blender 2.71, alpha blending or opaque seem to not work properly, or only work when they’re selected like so.

So i thought “ok, maybe it needs to be in the play game mode?” but that did this…

But the worst thing is that its inconsistent, i have a plane with a shade of blue over the eyes and that looks fine but everything else looks terrible. The spot on the eye there also has an alpha.

Suggestions?

I’ve tried:
Reloading blender
cycling through all the alpha settings
setting premultiply on the alpha texture

What are your normals like? try ctrl+n?

Care to upload a blend for us to play with?

I’m certain the normal’s are correct, but one thing to note is that the problem only occurs with the geometry i modified/added since importing the model from another program. the problem does not occur when i paint on the eye lashes.

So i guess it could be a normals problem (though i think i tried everything)

here is the blend file.

Also second note i had merged all the groups to try to solve the issue so things look a bit different now >_>

Ok turns out one parts normal’s were bad but my problem persists that the sky can only be rendered and the eyes aren’t visible.