Problem with Alpha rendering in games engine


(Nicolette) #1

Hi
I seem to be having a problem with alpha textures in the games engine. basically although I can certainly get alpha textures to work and can use alpha texures for such things as trees, glasshouses, glass, complex structure made of steel girders etc.

The problem is that where there are a number of objects that have alpha texures spacially in front or behind each other all the objects in the background show through objects in the forground which obviously gives an effect that is pretty useless really, well it looks like x-rayitus

I seem to have tried everything my latest trick which has entailed creating texures where the areas that are meant to be transparent I set to 97% alpha instead of 100% this seems to have helped aleviate the problem a bit, but it is still there and when I tried creating a model of a large green house with nice semi opaque alpha rendered windows, all the plants and shrubs inside which also use alpha textures are negating the alpha in the glass walls of the greenhouse, so it just ain’t working, it looks like the day of the triffids :frowning:

I’m wondering therfore if there is something simple I am missing or if it is problem specific to my graphics card (it’s a Nivida G-force card BTW) Or is it just a limitation of the Blender games engine?

Basically I am trying to create some fairly complex interactive walkthrough landscapes somewhat simlar to Active Worlds" However this problem with alpha rending does seriously limit what can be achieved since given the complexity of the stuff I am trying to create alpha texturing is essential inorder to keep the polygon count down and obviously without alpha texturing one realistic looking tree model is going to be one tree too many :-?

Nicolette


(OTO) #2

Hello
i’m guess that i don’t really understand your problem, but to me
and my Gforce all’s fine.
Diferent objects with or without Alpha textures in front or behind all are
correct.
Sure, if you want to “go” behind a window (interior) you must enable
Twoface for the facews
Bye
António


(Nicolette) #3

Yes I suppose it is a little difficult to explain. Basicly objects that use alpha textures interfere with each other and kind of ghost so if for example you have a clump of trees. The trees in the background that should be hidden or partially hidden by the tress in the foreground strike trough the trees in the forground completly ruining the effect.

I first discovered this problem when I tried to create a sort of model Park where I used alpha texture to create the trees and also to make the edges of the paths look irregular and blend with the grass, as paths in parks tend to do in real life. Unforunately in that case all the paths were just cutting strait through the trees and it didn’t look very good at all. In that particular case I got around this by creating a kind of sandwich for the trees basically using two panels in effect back to back with an opaque mesh in between, which was easy enough to create using a subdivided plane and the selection painting tool to remove unwanted bits. then using the decimator to simpify it and cut down the polygons. It worked but obviously after duplicating about 100 trees the extra polygons did start to slow movement in play mode down too much and in terms of polygons it wasn’t an ecomomical way of doing things and to some extent defeated the object of using alpha textures.

I must admit I have got to the point where I have seemed to have tried everything now and am beginning to think that this must be a bug in the Blender Games engine itself or the way that it works with my video card.

It certainly doesn’t seem to be a problem in other games engines, for example I occassionally use Active worlds and also I run Warbirds III both of which use alpha texturing on a near industrial scale to create naturalistic effects whilst keeping polygons to a minimum. I have also not noticed it in Blender games created by others. Though to be honest I have never seen anything where alpha textures have been used a great deal and where used tend to be used in isolation so it is difficult to tell, though I suppose if people are keeing alpha textures to a bare minimum, it would seem to indicate that maybe I’m not the only one to discover this problem?

That said I’m still only a beginner in some ways with Blender and in creating interactive environments so I certainly wouldn’t profess to know everything and since otherwise the Blender games engine would be quite up to what I am trying to do it seems a shame that it does seem to fall down with alpha textures or at least I just can’t get it to work right.

Obviously it’s a little frustrating not knowing whether it is something I am doing wrong or a limitation of Blender itself. If it is something I’m doing wrong it would be great to be able to solve the problem. However if it is a bug within Blender it would be nice to know this, and of course one could then work within it’s limitations. In lots of other ways though, Blender is a very nice bit of software particularly since it is free and obviously one can forgive some of it’s limitations because of this. However if this alpha rendering problem is a bug in Blender obviously it would be quite a huge improvement if it were solved and would vastly extend it’s potential.

Nicolette[/img]


(OTO) #4

Welll, most begginers (and the olders too) became frustated with Blender cause
there’s some misunderstandings about the game engine.

Blender it’s not (unless someone appear to prove me the contrary) a Quake or Unreal
or NOLF game engine tipe.
Please forget the thousands of polys, and characters and specials XF and all the
magazines “crap”

Blender is (to me): a fantastic GUI, a great low poly modeller, a nice WEB-ENGINE/PLAYER
badly explored, and a fast prototipe-game tool.
You can show to others what you can/know to do easily

And a great animation FREE/LINUX tool

When using alpha to make trees enable the halo or bilboard button
this way they’re always facing the camera view

Bye
António


(Nicolette) #5

Thanks Oto
I shall try the billboard or halo effect it may help solve the other problem to. Up till now I have been making trees with panels crossed over in a kind of “X” fashion but have realised there is a better way, once I work out how to stop them floating in mid air on their side when I enable bilbord or halo. I’m sure there must be a simple way round that one LOL :wink:

I would agree to, that the Blender games engine certainly has it’s uses inspite of limitations particularly since Blender Publisher is now freely available and one project I have in mind is to create a 3d art gallery to show a selection of my work to pontential clients and employers and I think that would be well within its scope and could work very well as long as I keep the trees and greenhouses to a minimum :wink:

Nicolette


(Nicolette) #6

Well I’m pleased to say I managed to get around the problem I was having in the games engine with alpha textures showing though each other, at least in the case of my greenhouse.

I took all the “glass” areas out of the texture graphics but retained greenhouse framework. I then made a duplicate of the entire greenhouse and joined it as one mesh. To this I applied a flat dark grey nearly black texture and used “ADD” instead of “ALPHA”. I’m plased to say the plants inside the greenhouse now sit nicely behind the “glass”… Magic :slight_smile:

I still have problems with alpha rendered objects showing through eachother, but there do seem to be ways to work around this.

Nicolette