Problem with appending minecraft rig

I’m just starting out animating in blender, and I’ve been having a lot of problems importing rigs into my scenes. I’ll select everything in the objects folder and append it, and I get this.


I’ve also tried grouping everything and appending the group, but same issue. I think it might be a problem with MCPrep, as the rig is fine until I prep the materials, but I’m not sure. Like I said, I’m REALLY new to blender and don’t know what’s causing the issue. I’m using 2.79 right now, but this issue also happened in 2.82. I’ve also tried with 2 different rigs, with the same result. Any ideas?

Need some more information to help:

  1. What version of Blender were these rigs and objects created in, and for what render engine?
  2. What do you mean by “prep the materials”?
  3. What do you expect the rig to look like? Can you show us what it looks like before being appended to another project?
  4. Does the issue persist if you append only the character mesh object and not everything else?