Problem with baking textures.

Hello!

I was following a tutorial for making a building. Problems started to rise when it was time to texture it and bake them.

Here’s the tutorial where texturing begins: https://youtu.be/3jJGBzAxXKo?list=PLQ75Wl83YWRE62Q2G5eSkv4J5rleJcRgO&t=2085

First I noticed, that when I tried to assign the material to my selected faces, it wouldn’t do anything before I chose the texture itself in the UV-editor. Texture-options in the right sidebar didn’t to the trick. It did rise some concern for me but I still continued on. Another problem I noticed, that I couldn’t combine multiple textures in the same way as the guy in the tutorial did. Meaning that he used one brick texture and used another texture to color it using different settings. Those didn’t work for me for some reason.

When I managed to put the textures on their places, made the new UV-map Object Data and followed the tutorial’s instructions for baking, it either only added one of the textures on every face (air conditioner texture on the building’s walls doesn’t look good) or just baked a black texture.

I tried to delete all the materials, do the texturing again following what the guy did in the tutorial. He didn’t go that much in-depth about his texturing process as he didn’t want to focus on that. Anyway, I still got the same results.

Here’s the link to the blend-file. If you’re wondering, the name means “building” in Finnish.

This is the first time I do the texturing like this. I usually just bake ambient occlusion and do the texturing mostly in photoshop but I noticed that this would speed up my texturing a little bit.

Hopefully some of you guys can give me a hand with this! Thank you beforehand!

Not looked at the baking but check your material textures.
For example the Tille material has two textures assigned and the second texture in the stack is the one you will see (textures are applied from top to bottom) and does not look correct.


Change the viewport shading from Multitexture to GLSL to see the actual material textures


Thank you for quick reply! And you also gave the solution to my problem! :slight_smile:

Thank you for your hard work for the community as well. Even if I am new here, I’ve lurked the forum before to find solutions to my problems before and I’ve noticed you are replying quite often. Kudos to you!

Right, it seems I was a bit too hasty. Baking went ALMOST right this time, aside from the brick (tiile)-texture:

It should look like this: https://www.dropbox.com/s/a1yd4bp6h2k618j/TexturesCom_BrickLargeBlocks0022_2_M_EDIT.jpg?dl=0

Other textures baked fine. Any idea what could be causing that? Something wrong with the UV maybe?

Thanks in advance!

Updated .blend-file: