Problem with cube map textures

Hi! I tried built in Cube Map texture rendering but I can’t apply my rendered texture to my object:

http://www.pasteall.org/blend/35883

Am I missing something? Thanks!

Not sure what the problem is. It worked fine in your video and when I tested it out. I think you might want to UV unwrap it, but like I said, I’m still not sure what the problem is. You said you can’t apply the pre-rendered texture to your object, yet you did.
Also, narrating what you are doing and where the problem is in your videos might help

I wanna found out how to use theese too, so that I can make PBR looking games…

set the map to reflection?

BPR, do you know how to make a cubemap texture(placed in that input) work in BGE? There was a script ago, but for old blender versions(about 2.5)…

Hello! Thanks for your answers and sorry about the lack of explainations. I don’t know why, I thought that was possible to have realtime reflections on a sphere (when you press P, see the same thing that you can see in the material tab) without python (or GLSL) script to map the texture correctly. But it seems that’s not the case. Or am I mistaken again?

There is need for script tu use them in this section, but… The old script doesn’t work on 2.6+ anymore. I am still waiting for someone to create a new one!

Hi! What script are you talking about adriansnetlis? I could try to update it… The Martinsh’s one?
@dancreator: Yes, I would like to have a correct unwrapping for cubemaps…

No! I can’t find it, but it binded a cubemap for game using all the textures that are formated as environment maps… I will look for it, but maybe it was inside of this file:

I was trying this code while you were posting. I don’t know why but for now, it does not work… I’ll make few experimentations.

Ah ok! It seems I have a problem with my envMap texture resolution. I don’t know why even if I render envMap texture with 512x512 resolution, I get this error message in the console:

invalid envmap size please render with CubeRes @ power of two
unable to initialize image(0) in MAMaterial, image will not be available

EDIT: That’s ok http://www.pasteall.org/blend/36100. Thanks! I changed resolution in the render panel instead of here:

Attachments


Wow… Thanks for a resource. Now, make a tutorial on how to use it;)

Ok. I’ll post it in a few hours in ressource section

By the way, why I can’t control that texture’s data like color amount etc.?

You have to modify GLSL script…

Oh… Why is it always so difficult?:frowning: WHen will Blender Game Engine finally use PBR?!

Well, I didn’t see that!