Problem with different thing in viewport.

Sorry, but I couldn’t find it anywhere, could any one tell me what is this green rectangle, and how to make it go away? It is horribly annoying, and I don’t know how I turned it on… Thanks.

Thanks so much for your help!

Check in the Object / Display options. Turn off ‘Texture Space’ if it is enabled

Hi, thanks for your response. I checked but it unfortunately didnt turn it off :frowning:

Supply a link to download your blend file

Here you go:


As I said, turn of Texture Space

Of course! I had two objects with pivot in the same point! Turning it off semed like it didn’t change anything, but now I checked both objects and it worked. Thanks so much!!!
Thread ready to close. Thank you!