Problem with DubliVerts


(MoreK) #1

Hi
I’m having a problem with my current Blender scene. I created fake global illumination effect by using DubliVerts:

  1. Added icosphere
  2. Cutted it half
  3. Added a spot lamp
  4. Linked it to icosphere (lamp/child, icosphere/parent)
  5. Selected DubliVerts in Animation buttons (& did some tuning to point spots to center of icosphere)

It worked fine at first, I could render nice pictures with GI effect. But all the sudden I lost all dublicated spots, they simply vanished! And I can’t get them back! If I select any other file or create a new it works fine. But not with this one.

Yes I know I could import all object to a new file and create a scene from scratch. But maybe some of you can help me with this, maybe I just miss something.

The file that don’t work is here. It’s only 37KB.

http://more.mine.nu/blender/temp/test.blend

Thanks!

  • MoreK -

(BgDM) #2

OK, I played with your blend file. It looks like you just forgot to flip the normals on the isosphere before you hit the dupliverts button.

Fix that and all should be fine. Worked when I did it anyway.

BgDM


(MoreK) #3

Thanks a lot checking this out.

Now, this is weird: I can make the test file work fine with Creator 2.23. The problem is only when I work with Publisher 2.25. Can anyone confirm the same problem?


(eeshlo) #4

The 2.23 blendfile does not seem to be compatible with 2.25, but it will work if you create it in 2.25 and then save it. I guess it is one of the bugs of 2.25…


(MoreK) #5

ehhh… I guess I didn’t explain it well:

  • created a file with 2.25
  • all in sudden DubliVerts vanished (just added couple of meshes and then - bang - all DubliVerts gone)
  • opened the file with 2.23 --> DubliVerts work again!

Now that’s weird…

  • MoreK -

(BgDM) #6

Has to be a bug then. That’s the only thing I can think of.

BgDM


(Eric) #7

Try open it in 2.25 again, sometimes blender f**** up a scene and most times that can be solved by closing and startup blender again.


(MoreK) #8

Yes I tried that several times.

Well, nevermind. As long as I can work with it in 2.23. Thanks for your help!