Problem with Edges always visible

Hey, Blender is showing edges when I’m working in Edit mode, but not just the edges that are facing me, ALL the edges are visible, making it really hard to see what I’m doing. I don’t know how it happened, and I can’t find a way to turn it off.

When I “reset to factory standards” the problem disappears, but when I reload my files, the edges are still persistent. As you can see in the picture, edges are everywhere, and faces seem to be half transparent or something.

[ATTACH=CONFIG]218752[/ATTACH]

Anyway I can fix this? Thanks if you can help.

Toggle that little button on the bottom of 3D view:


When you open a file through file -> open, there’s “load ui” option on the left side of the open file dialog. If you uncheck that, it won’t load UI changes that were saved in that file.

Hmm thanks for the tip! But that still doesn’t help with this problem, it’s like the faces are shrunk and transparent to a certain point, like a subdivide layer is automatically being applied or something.


It’s probably a 3D view setting, but I haven’t found it yet.

OK I started with a factory default setting, then opened without UI my file, and it’s all fixed :slight_smile: thanks. Still would like to know how to avoid this in the future though…

Press N to go to the properties panel and look at the clip start/end values. You probably had something like start: 0.001 and end: 100000, that will cause something like what you described.

Yep, you’re right. Playing with those values solve the problem.