Problem with eevee reflections

I was trying different hdri for the scene to render this corvette in.To make the car appear on the surface of the hdri i took a plane and added the same environment texture to it.After that i turned the scale of the plane on Z axis of the plane to -1.Now after getting the same settings for object as the world,the plane reflections are a bit different from the world hdri.You can see it rendered view.It is clearly visible.So changed i the output from surface to volume.THe tricked worked and the reflection became same as the background hdri.However now i am not able to cast shadow on the plane by using sun lamp as i was able to do in surface output.Can you help me sort this out?I want the plane same as background hdri so that the plane blends in with the environment and I also want the reflections at the same time. I am working on eevee. The node editor on right is for the plane object and the editor in the middle is for the world settings

Try looking for shadow catcher and reflection catcher materials or tutorials for eevee.

there is no shadow catcher option for eevee

I tried all possible things I know of to catch reflection.I tried all sorts of lamps and even tried using reflection panel from light probes but it went all in vain.

Do check my blend file though.

https://drive.google.com/file/d/1UIRXxcMrrCUwTwlMd1C6CJHGiq27ICO-/view?usp=sharing

I have a shadow catcher tutorial for Eevee https://youtu.be/XaGPVerxaGI

1 Like

I’m not sure I understand the question. Is this what you’re looking for?

1 Like

thanks for Helping.I finally sorted it out.Special thanks to Koumis for the tutorial.