problem with exporting to directx


I want to do some simple crossroads simulation (in Directx), so I start to draw my crossroads in Blender. This is my firsy use of blender. Everything was fine to the moment when i change something in UV (i dont know what:/ ). Now I can’t export to Directx, because i get error:

Traceback (most recent call last):
  File "<string>", line 860, in my_callback_sel
  File "<string>", line 117, exportSelMesh
IndexError: List index out of range

When exporting i select all (AKEY) and choose Export selected obj. I use this because when i choose Export all scene, everything is very small in DirectX Viewer.

Plese take a look on my file:

This is my first 3D model so i can’t hadle this ploblem. I don’t know what I did, but to this moment Directx export works very well.

I try export with script form blender site, but i get similar error.

I just downloaded your file, and I have the problem solved. I experimented with the exporter you were using, which seemed to corrupt the file. However, when I used the Ben Omari DX Exporter for Blender 2.41, it worked perfectly. You should go to his site at this address, and download the latest exporter: . It is very good to use; make sure to use ‘Export Object’ as well as ‘Flip Normals’ when in the GUI, since you apparently have nothing animated.

Hope this helps.