Problem with fluid simulation

Hi everyone. I just finished modeling a simple Wine glass and now I want to animate some red wine falling into the glass. Just to get started, I wanted to create a really simple and crappy looking simulation with just liquid. I had my wine glass be an obstacle, a large cube encasing everything as the domain, and a sphere as the liquid. Every time I try to create the simulation, I keep running into these problems, 1: The domain cube I have keeps changing its shape into some weird liquid shape when I set it to be the domain, and 2: Even when the simulation does run, the domain cube turns into the liquid, taking the place of the liquid sphere, and falling right through my wine glass. Solutions?

1: The domain cube I have keeps changing its shape into some weird liquid shape when I set it to be the domain,
That is correct behaviour. The domain object becomes the shape of the fluid in your simulation.

2: Even when the simulation does run, the domain cube turns into the liquid, taking the place of the liquid sphere, and falling right through my wine glass
Did you set the glass object to be an obstacle in the fluid sim settings.

Attach or post a link to your blend file.

This topic seems to come up at least once every week, with almost word-for-word identical questions and problems, right down to the wine glass. http://www.blenderartists.org/forum/showthread.php?289000-Is-there-a-way-to-erase-extra-water-in-liquid-sim

Ok, I went and watched a load of video tutorials and now I understand the fluid simulator much better. However, there is still one problem I keep running into. For the past 6 hours, I’ve watched tutorial after tutorial on getting fluid to run through a pipe. I have tried basically everything. I can’t get the fluid to interact properly with the pipe. If one of you guys could post a detailed walkthrough on getting a fluid through a pipe, that would be great.

Show us what your problem is
Show us your blend file. Link to upload your blend file already given.

Getting fluid to flow through a pipe is going to be the exact same process as getting it to flow through the wine bottle in the thread I linked to. Read through it all and look at the last few demo files in that thread.

Water Simulation.blend (860 KB) I followed the guy in the tutorial and I just don’t understand why my simulation is not working. I would guess it would have to be his tube being built differently because he doesn’t show you how to build a working tube.

Your fluid resolution is pitifully low, increase it
Set the Viewport display to Final, not preview
Your domain is way way way too large so you are wasting precious fluid resolution. Mak the cube as small, small, smal as you can
Clear the scale of all objects (Ctrl+A)
Make the inflow object smaller and give it more -z inflow velocity
Use a proxy tube which has a slightly smaller diameter so when you render with the original tube the fluid won’t intersect the walls.

Attached is a quick modification to your file


Attachments

Water Simulation.blend (403 KB)

After reading your fixes, I just about died from laughing because I understood almost nothing. I appreciate you helping me fix this problem. I just have a couple more questions. 1: What does clearing the scale of all objects do? and 2: What is a proxy object? Just remember, I started using blender last week. Go easy on me.

  1. If you have an object selected and are in object mode, press the “n” key with your mouse in the 3d viewport. In the sidepanel that appears, you can see the scale of your object. It generally should be X:1.00, Y:1.00, Z:1.00.
    If you now scale your object up in object mode, these scle valuse increase. Especially for phisics simulations and animation, but also for many other operations within Blender, this is not a good thing (you generally want to scale your models in edit mode). So if you scaled your model in object mode, and you want to use it in a simulation for example, you should set the current scale your object is at to 1.00 for all axes.
    You do that by selecting your object in object mode, and press CTRL+A --> Scale (this applies the scale, telling Blender that the new size of the object should be regarded as 1.0/1.0/1.0(

  2. A proxy object is an object that resembles your regular object, but has for example a lot less polygons. Proxy objects are used in rigid body simulations a lot for example, to reduce the simulation time due to less polygons that need to be calculated.
    In your case, a proxy object would be a second tube in the “same” position as your regular tube, but with a smaller diameter, as Richard Marklew said. You set this proxy object as the collision object. This way, if the fluid intersects with the collision object, it will not show up in your render, because it is not intersecting the actual rendered tube, but only the proxy object, which you set to not be renderable.

Ok, I understand. I know I’m asking a lot of questions but, how did you create the proxy object? I watched another video tutorial online and it showed me how to link/append an object but it didn’t show how to create a proxy object. I’m now starting to question whether or not appending an object has anything to do with a proxy object.

A proxy object is just a regular object that you’re using for proxy purposes. Calling it a “proxy object” makes it sound like it’s something special. For fluids, I usually model my container object (bowl, cup, pipe, whatever) first, then duplicate it. I take the duplicate and remove all materials, then move it to another layer and turn off its renderability. Then I add it to the fluid simulation and make it an Obstacle. Bingo, proxy object. Does that make more sense?

That makes much more sense. But now I just need to make the diameter of the tube smaller and I don’t see how that’s possible since I’ve already turned the bezier circle following the path into a mesh. Also, if I change the tube to glass, wouldn’t it be obvious that the majority of the liquid is flowing on the invisible proxy tube and not the actual tube when I render it?

Yeah, this would normally be easier if the object were not as complex as this. Here’s what I did:

  1. Select just the inner surface of the pipe. I did this by hiding the edge loops at each end of the outer surface, then holding the cursor over the inner surface and hitting L.
  2. Shift-D to duplicate that surface. P to separate selected as a new object.
  3. Rename new object to PipeProxy.
  4. Go into edit mode for PipeProxy. Recalculate normals to flip them the other direction. Go back to object mode.
  5. Add a solidify modifier with a thickness of 0.03. Apply the modifier.
  6. Back into edit mode on the proxy, repeat the same procedure as step 1, except this time delete the entire outer surface instead of hiding.
  7. Go back into object mode and add another solidify modifier with a thickness of…I don’t remember. 0.3 this time, I think. This adds thickness to the outside. Apply the modifier.
  8. Make this the obstacle in your fluid simulation.

A lot of steps, I know, but it’s just more complicated when you’ve already got a funky curved pipe to work with. Easier methods are available on straight surfaces.
Water Simulation.blend (649 KB)

Ok, after a while, I was able to get your steps to work. I did something wrong because my tube ended up looking kind of weird but the fluid doesn’t penetrate the walls. Thank you for your help!

Can someone help me ? bcause when i baked the simulation … the fluid seems not coming out