Problem with gorgan_almightys FMV-ed

I tried gorgan_almighty’s FMV-ed and boy it’s great!
I have a problem though and are hoping someone could help me out.
It’s working great when I run it in blender but when I do it in an exe nothing happens…
I tryed it with gorgan_almighty’s examle file, put the .py files in the same folder as the exe. I also have the .py files in the same dir as the blender prog. I even tried to have all the files in the same dir but nothing happens.

Can someone tell me what I’m doing wrong?


First you must notice, when you make a nw file and add some scripts and object, and you publish an exe without saving first, the added object an scripts arn’t in the exe. And did you pack the blend file, when you don’t do this and replace some script on your pc to another folder, the blend file can’t find them and will not work. Just pack your blend file when you add new things like textures and external py files.

Try saving as a dynamic runtime, and include the python20 and fmod .DLLs.

I’ve tried all that but It still won’t work. The exe works and it seems
that the exe adds the overlay scene but I don’t see the movie.

Maybe someone has a working exe that I can try. Maybe it something with my machine?

Hi Peter!

It works fine for me in exe form, so long as you have all the .py files in the right places, AS WELL AS the file. Try running the exe with the -c parameter on the end, that will force the dos console to stay open like it does in blender normally, so you can see any error messages that appear.

Another possible cause is that you’re running the exe in a resolution other than 1024x768 (look at the runtime settings on the File menu). At the moment, FMV-ed only works properly for games running in 1024x768. I’ve made a new version that corrects this problem tho, and I plan to release it as soon as I get a chance.

Hope that solves your problem pete, im still lookin forward to seeing a completed game that uses that util - mine won’t be finished any year soon! :slight_smile:

Keith. 8)

Thanks Keith!!
Got it to work… finally. :smiley:
Seems that was also needed in the exe folder.

By the way, is there somthing I can do to prevent the dos window to pop up everytime the movie are about to run? I can live with it but it would be great if it never showed…

Im looking forward to the new version!

My brother and I are hoping to be able to use this in our new project.


Yeah I did some extra testing and found that as well. It only seems to be needed for exe games for some reason tho. :-?

With in the same directory, fmv-ed runs with and without the console active (with and without the -c parameter), but for some reason fmv-ed seems to slip into the background, behind the blender game, when the console isn’t active. :-? Still trying to find a reason for this. Anyone know how to force a window to appear ‘Always on top’ in visual basic?? would love to hear from anyone who does. :slight_smile:

Keith. 8)