Problem with Hair Particles

When I add a particle System and turn to Hair, I have two problems which I can’t fix.


The hair does not follow the Vertex group which I set up as the density. Only if I turn to Emit from Vertecies instead of faces the hair is following along the vertex group.

The second problem I think is caused by the first one:

I cant add new Hair in particle Mode when I turned to emit from vertecies.

Does someone now a solution?

Free edit on the hair.
Change both subsurfs to the same, 1 1 or 2 2.
Make sure the hair is below the subsurf in the stack (up and down Arrows on right)
Check checkbox ‘use modifer stack’ in the particle system (at top)
change back to faces mode
particle edit, comb the hair.