problem with imported model - can't add anything to model...

hi there!

im rather new to blender and i worked my way in a bit so far. yet i’m far from being good at it…

i needed to build a model of a building for my thesis and as i had serious problems working my way into blender, i took the advice of a friend and modeled the building in google sketchup. this worked fine until i had to add materials to the model. so i had to import the model to blender. (in fact i exported it to collada wich can be imported by blender…)

after that there were 2 problems i had to solve: the model was wayyyy too big and all models that i created in sketchup were combined to one solid model. so i scaled the model, split it up again and added the materials needed.

and this is when the biggest problem showed up: i cannot add anything to the model. no cubes, lights, cameras… if i hit space, select about anything from “add” and click “ok” the object won’t show up… it actually shows up in the outliner, but not on the 3d view.
a friend of mine told me, this may be because of some “artifacts” that were created during the import by accident, which results in certain errors in the coordinate system…

the objects/lights/… i added as mentioned above happen to have coordinates like “-1.#IO” in the transform-properties window (for each of LocX, LocY, and LocZ).

is there any way to “repair” this mess? or: can i copy just the model of the building and paste it in another blender project?
i mean: is there ANY other way than starting all over again?

thanks to all who answer…

Have you checked “inside” the house model?
Have you checked other layers?
Do you know exactly where your 3d cursor is located (new objects will be added at the 3d cursor)
Have you tried moving the building and other stuff to another layer or temporarily hiding it when adding new objects?
If nothing else works, try selecting the newly added object and press alt+g(clear location)
and alt+s(clear scale)

Objects are added at the location of the 3d curser. If this is out of view or beyond the view clipping distance you waon’t see the objects when you add them. To reset the 3d curser back to 0,0,0 use Shift+C

thanks for the answers.

unfortunately, nothing seems to work :frowning:

what i tried:

  • resetted the 3d cursor to 0,0,0 by pressing shift-c => the cursor shows up at the origin as supposed to…
  • adding a cube. it won’t show up :frowning:
  • selecting this cube in the outliner, resetting LocX… values to “0” (each)… the cube wont show up :frowning:
  • switching to edit mode: the transform propoerties window now shows “medianX” and else, which are set to “-1.#IO” (each X,Y, and Z)
  • i hid the house-model to check whether the cude “hides” somewhere inside… nothing :frowning:

any other advice? would screenshots help to describe what i’m doing?

Delete the cubes and start again.
You may be in local view mode. Use Numpad / to cycle between local/global view
Helps a lot if you attach your blend file to your post (or other host site) so we can see exactly what’s going on.

thanks a lot. the file is attached…

Attachments

building_2356_v0630.blend (968 KB)

This should work now.
building_2356_v0630a.blend (257 KB)
Selected everything but the building and deleted them.

wow! this actually seems to work!

i wonder why it did not work for me - since i also tried selecting everything but the building - but it wouldn’t work for me…

anyways: can’t say “thank you” enough!!!