Problem with importing UV map from OBJ/3DS (Max)


I was trying to import T-rex model into Blender from obj file, and regardless of messed up scale and rotation, mesh itself looks fine. Unfortunately, UV map is gone and Blender cannot texture model properly. Since I have access to 3DS Max 2012 at work and it opens original MAX file without any problems, I tried export it by myself to 3DS and FBX formats, but still no luck. Geometry is ok, mapping is not. At best I’m getting something like very low quality ‘project from view’ UV, but it doesn’t match texture at all.

How to fix this? Is there any way to export only UV map from Max and import it into Blender?


I am afraid there is no cure. I’ve checked the model. It is not unwrapped. Yes, you can do one thing. Do a Retopo an bake the textures from original to retopo.

Sadly or not… I’m not using 3DSMAX anymore, but If I remember well, if you want to export uvs, and I guess you know it, you have to check a checkbox called " Texture coordinates". Normally, doing it will export your uvs correctly if they are good inside 3DSMAX. And maybe, uncheck “texture-coord” in the optimize tab,or leave it, do some tests, I don’t see why you couldn’t export them rightly.

Also, If I remember well, you can select “Blender” as preset to export your OBJ.

Another tip, maybe doing a reset X-form inside max before exporting would do the trick, I remember I often solved troubles this way.

Hope that will help.