Problem with LSCM Unwraping and Seams

I have made a model that I have added seams to. I think all the seams are connected in the correct places. I have one seam down the front of the torso and one down what should be the spine and on on either side unter the armpit down to the waist. The LSCM unwrapping comes out ok with one problem. on half of the front torso is unwarpped. The other half (right side of the model’s torso) gets unwrapped with the back and the heard.

Go here to download the blend file in zip format to see what I mean

www28.brinkster.com/sysop83/claudia12.zip

What I am doing wrongly??

I think I know what you mean, but let me rephrase to make sure.

You have two regions separated by seams: A, B. When you highlight a face in A and press “L” to select adjoined faces, you get all of A and B highlighted. But when you highlight a face in B, then press “L”, you only get faces in B highlighted?

I have seen this behaviour on my own model when trying to get seams right for unwrapping, but when I actually do the LCSM unwrap, my regions are correct on the flat map.

This is very odd behaviour, but has been a minor enough bug for me that I haven’t bothered mentioning it on forums, but if it really is affecting you, maybe it’s a more widespread bug than I at first thought?

There was a bug as explained by PhiloVivero in 2.34. I’d be very interested to see a simple .blend that still has this problem in 2.35.

As for the claudia12.blend. There is some weird behaviour, but it seems to be caused by internal geometry, which LSCM doesn’t like (this makes sense since there is no good way too unwrap that).

Look for example at the neck, or both sides of the face down to the shoulder. If you turn on Draw Faces in Solid draw mode, the problem areas will immediately become clear. After fixing that, everything went fine here.

I think I know the one you are talking about. I do not know how to correct them so I just deleted vertexes. When I did the the LSCM came out worse the before.

Is there any way you can post the corrected blend or a screendump of exactly the faces you mean and how you corrected it. I just deleted vertices but the unwrap did not come out any better. I was different but not any better.

Here’s a corrected and uv mapped version:
http://users.pandora.be/blendix/claudia_uv.blend

Some hints:

  • Don’t pin too many uv’s. Only a few pinned uv’s are needed to tweak your islands.
  • Unparent your mesh (from the armature) while uv mapping, makes switching between editmode and uv faceselect mode easier.
  • You might want to rethink the seams for the feet / shoes.

ok I looked at the new blend blendix. You change the seams around the face and the feet. I wonder if that had a greater effect on correct unwrapping then those internal faces did.

No, I first corrected the mesh, without changing seams, and unwrapping was fine. Then I rearranged the seams so there were less islands.

I’m going to show my ignorance here… I pin every UV coordinate in my models… I didn’t know there was any other way. What are islands…?

[edit]

I looked at the Suzanne unwrapping example. http://www.blender.org/modules/documentation/htmlI/x5336.html and I guess this explains what islands are.

There must be a better way to do texturing… <sigh>

I don’t see why you would want to do that? For LSCM you only need to specify roughly how you want your island to be shaped, by pinning a few UVs (these are mostly on the border). It will then interpolate the rest of the UVs.

I think the above claudia_uv.blend shows pretty well how this works. Most islands have only 2 pinned UVs. The feet are not a very good example of how to mark the seams, but they show pretty well how you can get the islands in a usable shape by pinning five or six UVs (try unpinning one of the two feet and unwrapping that to see the difference).

I usually first mark the seams. Then unwrap island per island. For each island I pin and move the two outer UVs (to make it look more symetric) and re-unwrap. Then I keep pinning + moving an extra UV and re-unwrapping until I’m satisfied with the result.