Problem with Lsystem

Hi, I have seriuous problem with lsystem script.

I have set PYTHONPATH (I run it on a WinXP… dou!) as you can see:

C:\Documents and Settings\Administrator>echo %PYTHONPATH%

C:\Documents and Settings\Administrator>

and here:

Python 2.3.4 (#53, May 25 2004, 21:17:02) [MSC v.1200 32 bit (Intel)] on win32
Type “help”, “copyright”, “credits” or “license” for more information.
>>> import sys
>>> print sys.path
[’’, ‘C:\Python23\Lib’, ‘C:\WINDOWS\System32\’, ‘C:\Python23’,
‘C:\Python23\DLLs’, ‘C:\Python23\lib\plat-win’, 'C:\Python23\lib\lib-tk
', ‘C:\Python23\lib\site-packages’]

but when I run lsystem with blender 2.34 or 2.35a, I correctly see the GUI of lsystem but when I click on “Generate” I get this error on the console:

Traceback (most recent call last):
File “”, line 454, in bevent
NameError: global name ‘cos’ is not defined

So, beacuse I’m a programmer (not python, of course) I’ve replaced all cos and sin with math.cos and math.sin. I run lsystem again but now I get another trouble on console:

mmm… don’t remember exactly words, btw, message is: “what’s that fuc**ng lsystem_build” ?

So… have you any idea of what is wrong with my python ??? :<

Thanks in advance

…and I’ve set C:\Python23\Lib into blender as python path. but that still remains.


thanks but still doesn’t work.

have this message back:

NameError: global name ‘lsystem_build’ is not defined

I tried other scripts, some of them work perfectly. It seems that my blender can’t find functions defined by the user, as lsystem_build(), for example.

Can anyone help me?

If you’re indeed using the version modified for 2.28 by jms then all I can suggest is to make sure that the filepath in line 17 of is correct, with correct syntax, and that you make sure to delete any and all other versions or folders that have anything to do with L_System.