Problem with Material Textures

Hello! So I’m making a quick animation for my outro, and I added an image the same way on each of these planes, but on the two largest ones they dont show up:



Also for some reason, the brightness of all the images is a bit low, and I tried altering the brightness, and contrast.
here’s my file: https://docs.google.com/file/d/0BxtLreFIVnSWaGxZMFNadC1tQ1E/edit?usp=sharing

You do realise that the blend file you linked to has no textures and we can only see them if we have access to your computer desktop

For texture support questions ALWAYS include your textures ! You can pack them in your blend file from the File / External Data menu

Also please post support questions in the appropriate support forum

Moved from Blender Discussion to Support / Materials & Textures

Sorry about that, I have fixed the link and attched the files.

There are no textures in the .blend

I should have attached the file: https://docs.google.com/file/d/0BxtLreFIVnSWaGxZMFNadC1tQ1E/edit?usp=sharing
does this work?

There are still no textures on your file

Yeah, there are no textures. File -> external data -> pack into .blend. File -> Save as, enable “compress” option if the file size is too big. Upload to http://www.pasteall.org/blend/

Anyway, I already know what problems you have in the file.

  • All objects have their scale keyframed, even though that is not used in the animation. Object scale is not 1,1,1 for any of them and you have to clear the keyframes before applying the scale. Object properties -> transform, right click on the scale fields and choose clear keyframes. Do that to all mesh objects and then in object mode ctrl+a -> scale.
  • Both larger objects have double vertices. Edit mode, select all, W -> remove doubles, F6 to increase the merge distance. And
  • select all, ctrl+N to recalculate normals outside. Do that to smaller objects too
  • You probably have to assign materials to correct faces after that because some of the geometry is now gone
  • Using UV maps instead of generated texture coordinates gives more control. Select the front faces (face select mode, select one, ctrl+alt+shift+F to select rest), move to front ortho view mode and U -> project from view. After that you can adjust the UVs in the UV/image editor. When you switch texture mapping from generated to UV, they should render.

Ok, here it is: https://docs.google.com/file/d/0BxtLreFIVnSWdVVydG5SRTJlMTg/edit?usp=sharing
So sorry for the inconvenience, I did everything you told me to up until the 4th hyphen:
[- You probably have to assign materials to correct faces after that because some of the geometry is now gone]
(that and under I did not understand), Thanks for all the help so far!

That’s ok. We have textures now.

There still are some doubles



Options on the left are also accessible when pressing F6 after W -> remove doubles. Vertices aren’t directly on top of each other so you have to increase merge distance. This removes double vertices, and also edges and faces between them.

Because that step removes geometry, selecting all and recalculating normals (ctrl+N) is good thing to do. Next make sure correct material is assigned to those faces:



If you select one face and then press ctrl+alt+shift+F, that selects all linked flat faces. Or alternatively select one face, shift+G -> co-planar. Quicker to select that way. (Don’t mind the duplicated piece in the picture, did that just if I need to visualize that selection, but this is not hard to explain).
After selection, select correct material from the material stack and press assign. This makes sure that material is on those faces.

Next, if you switch using a UV map for texture coordinates instead of generated, it’s easier to position the texture:



Switch to front ortho view: numpad_1 to go to front view, and numpad_5 to switch between view modes.
Those faces still selected, press U -> project from view. This creates an UV map you can edit in UV/image editor.
Then switch texture mapping from generated to UV. If you change image mapping extension to clip, it means it cuts the texture where the UV area ends, but it only does so when rendered.
You probably want to scale it there UVs in the UV/image editor. S to scale, X/Y for axis. R to rotate if you need to. You can also mirror with ctrl+M, axis. Same keys as in the 3d view.

Awesome! Thanks so much, it works! Is there any way to make the background be more brighter?



That is what it currently is, and this is what the original image was:

Yes. You’ve set the image brightness to be higher than one in the texture properties -> colors.
If you don’t want lights to have an effect on it, set the material shading to shadeless.