Problem with Mirror and axes

Hi guys, I’m hoping somebody can point out my error. I am modeling a twin engine airplane, soon to be in the WIP section. I have modeled half of it and would now like to mirror it. I mirrored it the other day and it looked great, I did this in object mode, joined the objects, then removed doubles. However, now when I mirror it, something is wrong.

Here it is before mirroring,

and here it is after mirroring ( I know, I’ve got to duplicate it, but this is just to figure out what is wrong with the axis)

Can someone tell me why, after mirroring, it is at the funny angle?

Thanks guys.

It looks as though you are mirroring about the local axis rather than the global axis and the local axis is at that angle. Try mirroring about the global axis instead. You should turn on the axis display for your object F7->Draw Panel->axis to confirm. If you want to change the local axis to be the same orientation as the global axis do a ctrl-a in object mode with your object selected.


Hi Greybeard, the ctrl+a trick worked great. I was mirroring over the local axis because that’s my only option in object mode. In edit mode I can mirror over the global or local axes, but in object mode I’m limited to only the local. Is there a way to change this?

By the way, I watched your tutorial on chess piece making and extended it to this, my very first render.
Let me know what you think. Look for my aircraft model in WIP soon.


but in object mode I’m limited to only the local. Is there a way to change this?

I don’t believe so. Just mirror global in edit mode and then with the mirrored verts still selected press p to separate them into a new object.