Problem with missing light

Blender 2.48
I think this is some sort of noob problem, which I haven’t learnt to solve.
If got a lighting problem. In the file attached my light source is a sun. For I didn’t want pitchblack in shadowy spots I changed the shadow color to some sort of grey.
If you open the file you’ll that the sort of table in there is has a quite nice shadow on the floor, but the downpart of the table, self-shadowed, is completely black.
How can I lighten it up?
Is there any better solution than putting up more light source with complicated settings in different spots?
Thanks for any help =)
Arun Leander

Attachments

glas.blend (252 KB)

one word:

ambient occlusion.

Found in shading (F5) tab, under world buttons

If you scale down the large plane in your scene, your render will take less time.

6 words: ambient occlusion too slow for animation
then again, so are raytraced soft shadows
attached is a fixed version, using a hemi lamp for fill light.
if this is actually for animation, you should probably replace the sun lamp with spot lamp with buffer shadows.

Attachments

glass.blend (255 KB)

But if you look at the glas, it’s still black partly (in your fixed version)…
the same the bottom of the table . . . pitchblack:confused:

probably I just really hate having multiple light sources and dont want it to be needed:eyebrowlift2: