Problem with normal maps in Blender

Hello,

I’m having an issue with normal mapping in Blender 2.49b. I’m applying a normal map to a surface, and when viewed at a “high” angle it looks great.

http://www.shackell.org.uk/images/AssaultGun/WingBump1.jpg

However, when the surface is angled even slightly the surface appears almost completely flat.

http://www.shackell.org.uk/images/AssaultGun/WingBump2.jpg

Now obviously normal maps don’t work when the surface is very flat to the view, but I’m fairly sure the above render is wrong.

I’m pretty new to Blender so it’s very likely I’ve done something wrong. I’d be really appreciative if someone knows what the problem is or how I fix it :slight_smile:

Here’s my material properties (it wouldn’t let me post 3 images in one post).

http://www.shackell.org.uk/images/AssaultGun/MaterialProps.jpg

In your image you have your texture mapped to the colour. For a normal map it needs to map to ‘Nor’. If its a tangent normal map you need to press the Normal Map button and set to Tangent in the texture settings as well.

Add a link to your blend file (pack all the textures in it). You can post it http://www.pasteall.org/blend/

Sorry I spotted I posted the texture settings not the normal map settings. I’ve updated the image.

Add a link to your blend file (pack all the textures in it). You can post it http://www.pasteall.org/blend/

This still stands.
Lighting direction has a big impact on normal maps so not surprised if you see a big difference in viewing angles.

If I’ve understood correctly it isn’t a tangent map, it’s a standard bump map.

Blender file is here

http://www.pasteall.org/blend/6990

I’ve tried messing around with moving the light … but it doesn’t seem to change much.