Problem with normals baking (noise)

I’m trying to bake normal map from my high-poly tire to the low-poly mesh.
But when I bake, I end up with this noise monster instead of normal normal map.

I tried cage and different ray lenght, but it doesn’t worked so far.

Any ideas of what I did wrong?
Any comments are very welcome

BTW, File with my mesh:

Set your cage extrusion to .01 to start. That’s in blender units, so the distance you’re using is literally half a default cube away from the surface. It will also help to bake your source normal higher res than you want the final to be and save it as 32-bit full float OpenEXR. Then when you’re happy with the rest, convert it to targa/png/tiff or whatever you’re putting in engine. Yeah, it’ll make a fat file, but you want that for your source file.

edit: add screenshot:

1 Like

This looks perfect! Thank you so much for your reply!
But I still failed to recreate this result(
May I ask how you created the cage in this example?

I just copied my low-poly mesh and scale it up in edit mode. Am I doing it totally wrong?
I also tried to create the cage using displace modifier, but so far I still gettin a ton of noise no matter it settings. Only once I saw something resembling lines from high-poly mesh.

I’ll try again.

Oh, I didn’t create a cage, I just checked the cage option and set the extrude value to .01 (see screen-- no cage object in the cage object box)

though if you want to do that manually, you shouldn’t just scale, you need to scale the faces along their individual normals rather than from object origin or other settings. Generally you don’t need to do this unless your mesh has overlapping areas, gaps, or holes in it that make other baking methods fail to capture those areas. Usually automatic cage extrusion and ray distance tweaks is sufficient for most cases.

edit: Oh, Forgot another trick you can use. Give your low poly a multires modifier and a shrinkwrap mod to your high poly. Then increase the multires divisions until satisfied. Then apply the shrinkwrap. This stores that high quad count in the multires data and you can bake from multires instead. This can also be tricky, but can also allow tweaking to the multires geometry before you bake normals.

1 Like

Wow, thanks a lot! I’ll give it a try.
And I finally got it :slight_smile:
There was some problem in 2.79, but 2.8 with your settings baked everything right away, I’m so glad I could cry)