Problem with normals (recalculate doesn't help)

I’m getting normals that point to the wrong direction, and the “recalculate normals” tool doesn’t work. Whenever I click it, it sets the normals seemingly randomly. I’ve tried applying transforms - no help. I’ve tried turning the double-sidedness on and off, but it’s no use (it’s still going to get exported single-sided). Is there any way to get out-pointing normals without going through every face manually?

SOLVED: It turned out to be a bug, it’s fixed now.

Recalculate normals relies on you not having a poor messy mesh

Before recalculating normals:
Remove any internal faces and non manifold edges (Selelect / Non Maifold in edit mode)
Remove any double vertices (select all vertices and W / remove doubles)

For individual faces that has a normal in the wrong direction select it and W / Flip Normals.
Turn on the normals display in the Properties panel (N) under Display while in edit mode.

I do know my way with mesh editing, this was not the case as it happened with the simplest of meshes. It turned out to be a bug and it’s already fixed in the nightly build. :slight_smile: