Problem with Object following Curve and Dynamic Paint

Hi,

i try to make a laser cutting Text effect like in this Tutorial:

Till now all is working fine, execpt one thing.
If my text will be drawn it looks horrible:


I think this is because if my Brush follows the curve it has too large steps.

Frame 1:


Frame 2:


See what i mean?

Every letter is a own curve. The laser should cut one letter in 40 frames. I tried to expand the frames, and tweaked with the evaluation time, but it didnt change much.
I also baked resolution up to 1024 but that doesnt help either.
Its like my brush doesnt touch the curve all the time but just in that steps. How to solve that Problem?

Heres the blend: https://www.dropbox.com/s/3bc8msabgvo54is/ATOC_Laser.blend?dl=0

Finally someone that shares .blend files immediatly! :slight_smile: Didn’t see the tutorial, but as far as i can see, is a mesh problem! Your mesh is not made of squares, but of rectangles, i don’t understand why you subdivided it this way, it would be correct if you recreate the object again, subdivide it with a few loopcuts to make squared faces and then use a subdivision surface modifier :slight_smile:

Thank you. I made a new plane and subdivided into square faces. It looks better now. But the main problem is still there.
Dont know why the edges are so jagged.

This is result:


And here with smooth modifier:


I really think it has to do with the Brush following the curve. If i scroll trough the frames the movement of the brush looks not like a
ongoing motion. It jumps to next position and then makes the displacement on the plane. But i need it more steady so it does not make that jagged edges. I want it to draw a line.

This is how it looks from the back:


I am stuck at this Problem almost 24 hours. Pls help if you can.

Well, as you pointed out, you can see steps, so as in other simulations, Increase the resolution and substeps! :slight_smile: go in the physics settings and increase the map resolution and the substeps, at least double them, you can also try increasing the curve resolution :slight_smile:

OMG, thank you very much! I did bake with higher resolution and more substeps before, so i thought it might be another issue.
But the curve resolution was the crucial point. So thanks again, you just made my day :smiley: