Problem with opening the same files on various operating systems

Hi guys,

I’m pretty new at, but I’m using Blender for 2,5 years so far. Few months ago I decided to install second operating system (Linux Ubuntu 12.04 LTS next to the main Windows XP) to test performance of Blender 2.6. Some weeks later I needed to check my blend files made on Ubuntu at XP, but Blender opened standard cube scene instead :mad: . I decided to ignore this problem and switch to Ubuntu to fix them. I used Blender 2.65.
Yesterday I downloaded the newest version in tar.bz2 to play with Dynamic Topology (BTW it bothers me a little transforming planes into triangles). Everything was good, I was happy with new features. Sadly, today I installed AMD video card drivers and Blender isn’t launching anymore (also Lincity but it isn’t a main problem). I moved the files to the Windows XP and I tried to open them. Unfortunately, instead of file, Blender opens standard scene and a message shows at mouse point “Cannot read file “file location” unable to open the file”.
Why Blender cannot open blend files made at Ubuntu 12.04? Both systems have 2.66 version and I can’t understand why I can’t edit them. On the other hand, I made only 2 blends but IMO the problem must be solved to make Blender works OK.

Sorry for my bad English, I hope someone will interest with my problem in Sea of Million Other Posts,

EDIT1: I had the same problem with blends on hard drive and memory stick. Here’s video recorded with 2.64 version

Ohh, I forget about something. I had this problem also, but with Blender 2.64. I cannot open at memory stick rigs, but on hard disk I could. Here’s link to video: