problem with rendering a texture

castle.blend (795 KB)

i am trying to create a 3d castle and to render a texture of a wallstone on it, however for some reason when i assigned the material to the inner and outer sides of the gatehouse the material breaks at the rendering(as you can see in the file i have attached,i hope the attaching actually worked). and i cant figue out why…? i already tried to play with the lights and repeat numbers but it doesnt seem to work

thank you all helpers

PS: apologies if i have violated a forum rule by attaching a blender file here

You haven’t packed your textures in your blend file (File / External Data menu) so cannot see what you see.
Looking at your model you have a huge number of overlapping duplicate geometry. Select all your vertices and W / Remove doubles. This removes 476 redundant vertices for the arched wall alone.

You’va also got loads of faces inside your mesh (see image). Get rid of it (see below). A messy mesh will give you a messy result.

hi there

thank you so much for answering me.
before i checked your reply i have tried to retrace my steps by creating a new model and on this one the rendering worked perfectly. i didnt know what was quite wrong with the previous model however now i understand.

i must have accidently created these overlapping copies without noticing it.
can you please explain to me how you detected them? because I cant see them :slight_smile: