Problem with right mouse button.

Hey all,

I am using a Logitech Performance Mouse MX and when I try to use the right mouse button to rotate the view, all it does is move my mesh all around. I have been having this problem for weeks and do not know how to fix it. Any help would be greatly appreciated.

Here is a link to it’s specifications page, if that helps any.

Use the MIDDLE mouse button. NOT the right one.
Left mouse button) Click to place the 3D cursor.
Mid mouse button) Scroll to zoom view, Drag to rotate view.
Right mouse button) Click to select an Object, Drag to move selected objects.

My middle mouse button only zooms in and out. I have tried holding it down, and also tried just clicking it once. I have another mouse that I have been using when I can that rotates the view with the right mouse button, and that is always how I have rotated the view.

The default blender controls are MMB for rotate so you either changed it to a custom command or have set something up in the mouse control panel. Go and look

I didn’t. I even uninstalled and re-installed Blender. I’ll look anyways.

Try File > Load Factory Settings
Then File > Save as Defualt

I see - File > Load Factory Settings
But I don’t see File > Save as Defualt

File -> Save user settings (CTRL+U)

Thanks again but that still does nothing.

Oh, sorry.

Check your mouse’s software settings. It could be they have some odd key combination mapped to the MMB and/or RMB.

What is the correct key combination that should be mapped to the middle and right mouse buttons? (Mine says “middle click” and “right click”).

I know other have mentioned it, but it sounds like you buttons are mapped to something other than the defaults in you mouse software. But then again if they work as normal in other programs thats a bit odd? :confused:

eitherway just map them to what ever you want. user prefs (control alt U) -> input -> 3d view -> 3d view global. then click on rotate and click the button you want to use on the mouse. That should do it.

Your right mouse is working correctly the way you describe though. If you single click it’ll select stuff, if you click and drag it’ll select and move. Other than that I haven’t a clue.

Try the Control Alt U thing again and click the INPUT tab at the top, then on the left look for Emulate Three Button Mouse and turn that on.
I have to use ALT Left Mouse Button after doing this but it seems to be working so far (it was driving me nuts).
I’m on a laptop and I have a mouse wheel and no third mouse button and had the same problem, so far this seems to have fixed it.

This being my first post on this board I hope like crazy it helps!