Problem with shading / lightning of edges / faces

I am currently working on a model of F302 (one of my first models, i don’t got alot of experience though).
So first of all a reference image how a F302 look like:

I want all faces on my picture below to be shaded as flat and not as smooth!
However when I render the part i have already done I end up with the following:


As you can see there are flat surfaces (for example the cockpit glas) which should be one face, however it gets rendered as diffrent faces and you can see the edges of the triangles. If I look at the faces in edit mode, the faces are actually one face and not two. I understand that the GPU only renders triangles and therefor splits my quadrangles into triangles.
Can anyone give me a hint how I can get rid of this?

I am using a Area lamp with “Ray Shadow”.

Thanks in advice
RononDex

Since since your model is triangulated at render time, non planar faces will show as two visible triangles.
You can select the face and use W / shade smooth to selectively set the shading of individual faces or set the whole model to be smooth shaded and add an edge-split modifier and use the edge angle value to control the sharp edges and/or mark selected edges as sharp with Ctrl+E / mark sharp

Thanks a lot!

After doing what you suggested the faces on render look correct now :slight_smile:

Here is my actual render (after setting some initial edges to “Mark as sharp”)