Problem with shadows only

Hi, I use Blender 2.5.
I want to use the “shadows only” function in a simple scene with some cubes. As far as I can see all the options are set:

Point lamp - Ray shadow
Surface that should receive the shadow - Traceble disabled, Receive and Shadows only enabled
Cubes - Tracable enabled
Render menue - Shadows and Ray tracing enabled

The shadow doesnt appear on my surface. Without shadows only activated I can see the shadow en the surface. Is there another option that I have to enable or disable?


Do you have ambient occlusion or Environment lighting enabled? I’ve found that this setting will often prevent shadows-only stuff from working. (I’m not sure WHY it happens, but it does – with AO you see the shadow on the visible surface, but it disappears on the shadows-only surface)

I haven’t had any problem with this in either of those ways, but I have when indirect lighting is used. You don’t have to disable traceable for the ground plane when set to shadows only. With my tests it made no difference. A blend file may help to see more of what is going on.

I’ve spent hours struggling with this issue myself.
My guess is you have either “Environment lighting” or mesh lighting (Material>Shading>Emit) turned on to brighten up your scene.
This isn’t real light! It is faked. Blender doesn’t have real “Environment lighting” like other 3d apps. It probably will later, but not now.

If you don’t have a real Light (point, spot, etc.) turned on to brighten up your scene then a shadow-only light won’t cast a dark region onto a mesh.

Think of it this way. Without a real light in your scene, your scene is completely black. If it’s completely black then you can’t see any shadows can you. For all practical purposes consider your scene to be black (no light) even if you are using either “Environmental lighting” or mesh lighting. I know it doesn’t look black, but it is. What you’re looking at is fake light!