Problem with smooth

Every time i try to smooth this car that I exported from Roblox this happens



I don’t know if i can fix this problem.

Hi Bobs_Burger,

Subdivide your model (in Edit mode or use Subsurf modifier in Modifiers stack).

This might be a shading error due to imported vertex normals, which are colliding with Blender’s attempts to generically smooth the mesh. Try this

In any case: You should ALWAYS provide an example .blend file with any support question. Otherwise you’re forcing uns all into a tiring (and possibly pointless) guessing game.

Also, maybe Normals Recalculation (in Edit Mode) will help you.

Okay i included the blend example

While in Edit poly mode

Hit W, select remove doubles

After that,

go to object mode
then hit space
then type in (Clear custom Normal )
then click on the only option

Problem solved.

I did you method but it solves half of my problem every time i try to use subdivision surf
it does this
I removed double vertices and did limited dissolve but nothing worked.

Blend file :
had to use this because upload keeps failing
I doubt this problem will be solved

That’s because your model was exported as many different boxes. I am just not familiar with Roblox, but maybe there are some options available when exporting from it (like a single peace)?

Ahh, move your light and camera to another layer.
select one piece of the car, hit CTRL+I to select all other pieces, not shift+click and reselect the first piece. CTRL+J to join as one object.
Then go into edit mode, select all CTRL+V and remove doubles, every section is separate, so even shaded smooth, the point where blocks of polys meet will be sharp.

EDIT: Scratch that, the model is rather a mess, in all honesty, I’d simply use this as a reference for retopology or even just b background model to work from.