problem with subsurf. Noob in distress :(


(sixleaf) #1

Hey im very new to blender. Anyhooo probably a very dumb question but here goes. I was modelling (a very very boxy gun if you must know) Anyway half of this was done through extruding a cube out, and the rest was from generating in faces by selecting four vertices and then pressing f. Anyways a few mins in i got bored and wanted to see what it’d look like when subsurfed and smoothed. was all okish but when i selected it all, and subsurfed it, i got lots of weird joins where i had added faces im myself, the rest of it smoothed fine. How do i fix this?

Oh and another question…in order to get some faces in the right place i knifed in extra geometry but this made trianges, anyway to make it make quads? (yes i saw the post lower down in the forum about this but it went over my head when he said innvar or something)

Hmm thats all, thanks for any tips.


(lococobra) #2

Your normals are missaligned.

In edit mode:
Akey for select all - Space bar for menu - Edit - Normals - Recalculate outside


(sixleaf) #3

nope no luck doing that…the weird joins still there. :frowning: it just seems to smooth the faces separate to the rest of the mesh. have a i missed a step somewhere to fully join up the faces or something?

to show my problem heres a 2 cubes joined together with 4 faces and then subsurfed

http://www.sixleafclover.worldfreeweb.com/images/example.gif

instead of making one long sausage it makes it all segmenty. Why? And how do i fix this?

sorry if i wasnt clear about my problem


(Fligh) #4

If you cut that object in half you’ll find that the internal faces of the original cubes, where you have covered them with the newly created faces, are still there. Since they react the same to being subsurfed as do all the external (visible) geometry, they are pulling the surrounding faces inward.

%<


(cerin) #5

So select the a set of four vertices on one side of the middle cube then hit x->faces and then do the same thing with the other side but don’t try both at once or it will delete a few other things. There is probably a select mode that allows you to do both at once, but it isn’t necessary to know.


(sixleaf) #6

ooo everyones so helpful, its refreshing. Thanks guys, it half worked. Well, it fully worked for the segmenty sausage, but i went back to an early stage of my gun, and even with deleting the faces that i covered up, i was left with this.

http://sixleafclover.worldfreeweb.com/images/example2.gif

:frowning: its not fair, if it worked for the sausage why not for the model where i actually need it to work

I found out that if i delete the faces just below where the lower “pinch” is and replace it with just one, then the pinch shifts down to where that new face meets the old. Don’t know if this helps identify the problem at all?


(Fligh) #7

Select all verts in Edit mode and (W-5) Remove Doubles, then Ctrl-N.
That might not fix it though. There’s a vert at the end of this fold here:
http://img.photobucket.com/albums/v625/fligh/example2.jpg

And it’s invisible. So, it may be leftover internal geometry, or it may be from a face in a model (maybe an exact duplicate?) that’s not selected. Toggle Z to get into wire mode and track down the edge that’s folding and delete it or tweak it to fit in better.

%<


(PR) #8

The problem you have seems more like you have one face were before you should have two, not double vertex, nor internal faces. To better understand, look at the image below.

http://www.webalice.it/cyberave/blender/Problem.jpg

If you have used F to create a face between the four vertices that are most external, you do get a face, but the inner vertices, the ones in the middle of your edges, are not affected, and if you move them you see you have a triangular open face. Delete the face in the middle and create two smaller square faces to comprhend all the vertices.


(sixleaf) #9

oooo you’re exactly right, i get the lil circly holes when i move the vertices near the nasty joins. Hate to sound even more newbish but i cant figure out how exactly you meant to fix it. i’ll have a fiddle in the meantime. thanks again. you’re a genius


(sixleaf) #10

ok a little update. i managed to press F after selecting the three vertices around the triangle(circle) hole and that fixed it. still…i dont much care for triangles and how did you change your one triangle hole into two quads??