Problem with texture paint in 2.72

Hi there guys!

I’ve been having this problem and it’s probably silly and easy to fix, but I’m not sure what to do really.
I’ve been using texture painting in previous version without any issues and now suddenly I can’t do it anymore the way I did.

When I pick my texture (example in picture) I can view it in edit mode, but then once I click on texture paint everything goes black.
I tried clicking different things and messing around with settings, but I think I’m doing something wrong because it still doesn’t change.
Preview with texture in edit mode:



Actual texture paint:

I will be really grateful for help! It’s been really an issue for me for quite a while and it’s a bit annoying, because I have to add shading to my textures in photoshop and check them all the time if it’s alrighty. :l
sticky

Anyone?
Please? :frowning:

It’s new behaviour, now when you go to Texture Paint mode, Blender add a material if you didn’t had one, and add a black texture to that material if you didn’t had a material texture ( note that if you only had a texture assigned through the UV/Image editor, it does not count as a material texture) already.

To work on your original assigned texture instead of the black one, when you’re in Texture Paint mode, go to the “Slots” tab
http://i.imgur.com/2A7tUga.jpg

Then change the “Painting mode” from the new default “Material” into “Image”
http://i.imgur.com/QCKeJ6Y.jpg

And click on the Image button and select the image you had previously loaded in your UV/Image editor
http://i.imgur.com/dAyV4Xc.jpg

Yes, it’s not very intuitive, but should change sligthly in future versions hopefully for the better :
https://developer.blender.org/rBc03951da141497000dc9ab895f4f2299a5365c7a

Edit: Gah, Sanctuary beat me.

Thank You so much for help! just what I needed…sadly I couldn’t figure it on my own, and as always it was such a simple thing.

Thank You very much Sanctuary and xrg! :smiley: