Problem with textures in any mode but render


I have the same problem as many others with my ATI Radeon card…the slow background image thing. Well I have seen a lot of people say “UV map a plane, hit f7, set the animation settings to wire…etc…etc.”
Well I’ve done all that but the image wont appear on the plane or any other object I try (Tried different formats, colors, resolutions). It will only apear in Render mode.
argh…I hope this this question isnt stupid, but does anyone know of a solution?

Have a nice day,


You need to work in textured (found in Viewport Shading in the menu) mode.

Sorry, I forgot to put that. I have set my viewport shading to textured, but I cant see the texture on any objects.=(

What ATI card do you have exactly?
I once tested this particular method with integrated Intel graphics card and it only worked when the textures were small enough. When they were too big, they didn’t show correctly.

I’m on a Radeon 9800 Pro, 128mb
Catalyst 5.10

Everything works smoothly, no problems anywhere apart from these textures that wont be displayed…perhaps I’m missing something…

You could try to tweak your OpenGL settings in Windows(Display Properties\Settings\Advanced\OpenGL). That ~might~ have some impact. I have Mobility Radeon 9700 and I use Balanced settings without any problems .

The problem might be the dimentions of your image. Use GIMP or Photoshop (or gasp MSPaint) and pad the image out so that each side is a multiple of 8 pixels long.

Many times the graphics card will expect your mip-mapped images to have this size constraint, and will fail to operate properly if you use any other size.

The picture doesn’t have to be square, just a multiple of 8 on each side.

Hope this helps.

Thanks for the help so far guys, I appreciate it.

The image I’m using is 256x256…reminds me of my unreal mapping days sigh

Anyway, none of that seemed to have an effect on it.

Just checking, am I doing it properly here? what I am doing is:

spacebar->add plane then material->add new->F6, texture buttons->add new, switch texture type to image-> load image…thats all I do, then I switch the viewportshading to textured. :-?

You need to UV-map an image. Here’s a quicktut:

Somebody has got to make the “my textures don’t show up in textured mode!” thing a sticky. From what I’ve seen, it’s by far the most asked question.

Ok, thanks a lot! I really appreciate the help. :smiley:

Have a nice day,